Last modified: 2010-06-02 05:37:03 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23572 - Imagemap cannot accept dynamic links.
Imagemap cannot accept dynamic links.
Status: RESOLVED DUPLICATE of bug 2257
Product: MediaWiki extensions
Classification: Unclassified
ImageMap (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Tim Starling
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 19:40 UTC by Adam Cuerden
Modified: 2010-06-02 05:37 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Adam Cuerden 2010-05-17 19:40:26 UTC
Example:

<imagemap>
Image:Audio-card.svg|thumb|right|250px|Desc
rect 0 0 48 48 [[Template:Motd/{{{month|01}}}-{{{day|01}}}]]
desc bottom-left
</imagemap>


Fails because of the {{{month|01}}}-{{{day|01}}}  part. The non-dynamic:



<imagemap>
Image:Audio-card.svg|thumb|right|250px|Desc
rect 0 0 48 48 [[Template:Motd/01-01]]
desc bottom-left
</imagemap>

Works. This causes issues when using an image as a placeholder for a link elsewhere.
Comment 1 Roan Kattouw 2010-05-17 20:18:13 UTC
This is a known bug: {{{template parameters}}} don't work inside <tags>.

Fix:

{{#tag:imagemap|stuff that goes inside the tag}}

Will find the bug number and dupe this.
Comment 2 Raimond Spekking 2010-05-17 20:19:34 UTC

*** This bug has been marked as a duplicate of bug 2257 ***
Comment 3 JeLuF 2010-06-02 05:30:04 UTC
Done.
===================================================================
Index: InitialiseSettings.php
===================================================================
--- InitialiseSettings.php	(revision 813)
+++ InitialiseSettings.php	(working copy)
@@ -5143,7 +5143,7 @@
     'hewiki' => array(
         'user' => array( 'move' => false, 'upload' => true,),
 	    'sysop' => array( 'deleterevision' => true),
-	    'patroller' => array( 'patrol' => true, 'autopatrol' => true, 'unwatchedpages' => true ),
+	    'patroller' => array( 'patrol' => true, 'autopatrol' => true, 'unwatchedpages' => true, 'rollback' => true, ),
 	    'autopatrolled' => array( 'autopatrol' => true ),
     ),
     'hrwiki' => array(
Comment 4 JeLuF 2010-06-02 05:37:03 UTC
Ignore comment 3, this was supposed to go to a different bug report :-(

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links