Last modified: 2013-02-15 12:53:39 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23428 - Headers of collapsible (sub)menus in sidebar not accesible via keyboard
Headers of collapsible (sub)menus in sidebar not accesible via keyboard
Status: RESOLVED DUPLICATE of bug 24298
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Trevor Parscal
: accessibility
: 24582 (view as bug list)
Depends on:
Blocks: 367
  Show dependency treegraph
 
Reported: 2010-05-06 22:17 UTC by Danny B.
Modified: 2013-02-15 12:53 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Danny B. 2010-05-06 22:17:15 UTC
Headers of collapsible (sub)menus in sidebar (This feature is available on Commons only currently.) are not accesible via keyboard.

One can not expand the submenu and access its items.
Comment 1 Trevor Parscal 2010-05-07 17:53:11 UTC
This is resolved in r66029. Thanks for the excellent report!
Comment 2 Maria Schiewe 2010-07-26 14:44:01 UTC
While this now allows users to collapse the menu, it still is not clear to the user that he can do so. The element is still a heading level 5. No screenreader user will suspect that he can interact with the heading to collapse a menu. You must either insert some text indicating the possibility and/or use other elements that are known to the user for interaction, i.e. a link, or set the clickable attribute.
Comment 3 Derk-Jan Hartman 2010-07-26 15:22:47 UTC
This is a bug in screenreader software in my opinion. The onclick html attribute should be avoided in favor of DOM hooks. If the screenreader software then doesn't see it as a clickable element, then the screenreader software really ought to be improved.

Not saying that it doesn't affect accessibility, just saying that screenreader software producers have a responsibility as well here....
Comment 4 Maria Schiewe 2010-07-26 15:45:23 UTC
I don’t agree that this is a bug in the assistive technology. How should a screenreader recognize that the h5 can be interacted with? By inspecting all of the associated Javascript code? Hardly feasible. Here a non-interaction element (h5) is used to build some interaction. That is no good style, the element is misued. WAI-ARIA mark-up would offer a solution but isn’t supported by all screenreaders yet—and not by older versions.
Comment 5 Derk-Jan Hartman 2010-07-26 15:56:43 UTC
It's not a perfect world. I agree that it is HARD to do for assistive technology, but that IS where it primarily should be fixed. And it will, because the web is getting more interactive by the day. The idea that only interactive elements are capable of interaction is getting quickly outdated.

Now to get back on solving this. Adding a <a> element inside the <h5> ?
Comment 6 Maria Schiewe 2010-07-26 16:22:23 UTC
It will be fixed by “perfect world” programmers enhancing their code with WAI-ARIA, because to interact with an element you must know it’s interactive. *smile*

As for the solution, yes, I think adding an <a> inside the <h5> will solve the problem. Still it would be neat to have an indication about the collapsing. Normally, one could do this over the alternative text of the image, but here we have a background image that can have no alternative text.
Comment 7 Derk-Jan Hartman 2010-07-30 16:15:42 UTC
*** Bug 24582 has been marked as a duplicate of this bug. ***
Comment 8 Derk-Jan Hartman 2010-07-31 16:41:32 UTC
The Actions menu has the same problem. Suggest using <a> with a title attribute. (without a title element, some [VoiceOver] will repeat the title of the current page).
Comment 9 Graham87 2013-02-15 12:53:39 UTC

*** This bug has been marked as a duplicate of bug 24298 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links