Last modified: 2010-04-05 11:08:07 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23033 - unwanted linebreak when output starts with #
unwanted linebreak when output starts with #
Status: RESOLVED DUPLICATE of bug 12974
Product: MediaWiki extensions
Classification: Unclassified
ParserFunctions (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/w/index.php?t...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-03 13:29 UTC by Derk-Jan Hartman
Modified: 2010-04-05 11:08 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Derk-Jan Hartman 2010-04-03 13:29:25 UTC
{{#if:a| #ee2222|CornFlowerBlue}} introduces a linebreak before outputting #ee2222, causing the formation of a numbered list, but {{#if:a|bogus|CornFlowerBlue}} does not output a linebreak.
Comment 1 Bawolff (Brian Wolff) 2010-04-04 02:33:59 UTC
Note, as work around, {{#if:a| #ee2222|CornFlowerBlue}} works fine. (  -> space before it gets interperted as css.

This might be a duplicate Bug 12974 (that seems to be more to do with tables, but probably same underlying issue)
Comment 2 Thana 2010-04-05 10:34:09 UTC
(In reply to comment #1)
> Note, as work around, {{#if:a| #ee2222|CornFlowerBlue}} works fine. ( 
> -> space before it gets interperted as css.

{{#if:a|<nowiki />#ee2222|CornFlowerBlue}} also works.
Comment 3 Thana 2010-04-05 10:54:17 UTC
The usual behavior of the parser-function is to trim white-
space from its input, so I'd speculate #*:; are deliberate
exceptions to this, probably to _guarantee_ a line-break
with the following input, which may be a more common case:

List:{{#ifeq: {{{lang}}} | español | 
#Uno
#Dos
#Tres
#Catorce
}}

Note: even without these symbols being a special case you
could preserve the otherwise eaten line-break manually by
putting "<nowiki />" at the end of the first line.
Comment 4 Alexandre Emsenhuber [IAlex] 2010-04-05 11:08:07 UTC

*** This bug has been marked as a duplicate of bug 12974 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links