Last modified: 2010-03-26 07:32:03 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22957 - Add {{CURRENTUSER}} variable
Add {{CURRENTUSER}} variable
Status: RESOLVED DUPLICATE of bug 4196
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-26 06:54 UTC by This, that and the other (TTO)
Modified: 2010-03-26 07:32 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description This, that and the other (TTO) 2010-03-26 06:54:05 UTC
A {{CURRENTUSER}} magic word should be made available, which would return the name of the user or IP who is viewing the page.

For example, if I was logged in, and I viewed a page containing

  Your gender preference is set to {{GENDER:{{CURRENTUSER}}|male|female|unspecified}}.

I would receive the correct output. At present, there is no way to achieve the same functionality.

This magic word/variable could replace (or complement) the various My special pages. It would be more intuitive: if the following wikitext was present:

  Add the code to your [[Special:MyPage/monobook.js]] page

the user might believe the code is actually being stored in a Special location. But if the following was used:

  Add the code to your monobook.js page at [[User:{{CURRENTUSER}}/monobook.js]]

it would be instantly clear where the code was going.
Comment 1 Alexandre Emsenhuber [IAlex] 2010-03-26 07:32:03 UTC

*** This bug has been marked as a duplicate of bug 4196 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links