Last modified: 2012-04-19 21:43:08 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22894 - Template : Initially empty template parameters dropped from dialog, mess up dialog interaction for parameters below them
Template : Initially empty template parameters dropped from dialog, mess up d...
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Nimish Gautam
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-03-19 08:38 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_2010-03-19_Template_changetodialog.pdf (97.17 KB, application/pdf)
2010-03-19 08:38 UTC, Calcey QA
Details
Wiki_2010-03-19_Template_changetodialog_II.pdf (40.84 KB, application/pdf)
2010-03-19 09:21 UTC, Calcey QA
Details

Description Calcey QA 2010-03-19 08:38:45 UTC
Created attachment 7229 [details]
Wiki_2010-03-19_Template_changetodialog.pdf

Reporting against Babaco Release : r63938
Tested link :http://prototype.wikimedia.org/deployment-en/Main_Page

Steps to Reproduce ::

Please refer the attachment


Expected Outcome::
Changes done on dialog box should effect immediately on the expanded template


Test Environment::
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8
Comment 1 Calcey QA 2010-03-19 09:21:59 UTC
Created attachment 7230 [details]
Wiki_2010-03-19_Template_changetodialog_II.pdf

Value entered in the parameter is not updating in the expanded template.
Comment 2 Calcey QA 2010-03-19 12:12:24 UTC
Added the word Template for the caption for tracking purpose
Comment 3 Nimish Gautam 2010-03-22 18:39:07 UTC
While in the the dialog, we consider the user to be in an editing mode, similar to the other dialogs, and won't have the wikitext change until the user has confirmed and hit 'update'
Comment 4 Roan Kattouw 2010-03-22 20:50:23 UTC
(In reply to comment #3)
> While in the the dialog, we consider the user to be in an editing mode, similar
> to the other dialogs, and won't have the wikitext change until the user has
> confirmed and hit 'update'

That doesn't address the problem outlined in the first attachment and described in the summary.
Comment 5 Roan Kattouw 2010-03-23 14:28:29 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > While in the the dialog, we consider the user to be in an editing mode, similar
> > to the other dialogs, and won't have the wikitext change until the user has
> > confirmed and hit 'update'
> 
> That doesn't address the problem outlined in the first attachment and described
> in the summary.

An example article on which this happens is [[Berlin]]; I was playing with the template features on that article and noticed the parameter-value pairs in the infobox dialog are mismatched because of empty values.
Comment 6 Nimish Gautam 2010-03-23 23:44:21 UTC
Ok, I see what you're saying now. Allowing for empty values in templates. Fixed in r64099

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links