Last modified: 2012-04-19 21:43:36 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22877 - Dialogs: Insert Tables : Production : IE add all links and tables on top of the editor
Dialogs: Insert Tables : Production : IE add all links and tables on top of t...
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: High major (vote)
: ---
Assigned To: Roan Kattouw
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-03-18 10:18 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_2010-03-18_IE_err.pdf (53.75 KB, application/pdf)
2010-03-18 10:18 UTC, Calcey QA
Details

Description Calcey QA 2010-03-18 10:18:30 UTC
Created attachment 7219 [details]
Wiki_2010-03-18_IE_err.pdf

Reporting against Babaco Release : r59858
Tested link :http://en.wikipedia.org

Steps to Reproduce ::

1) Please refer the attachment

Expected Outcome::
Items should add on the cursor postition


Test Environment::
Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727


Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3)
Comment 1 Adam Miller 2010-03-23 05:15:17 UTC
This appears fixed on my local build and on prototype. I can replicate it on en.wikipedia.org, but no where else.
Comment 2 Calcey QA 2010-03-24 02:33:57 UTC
Verified against IE 7 and IE 8 on http://prototype.wikimedia.org/deployment-en/
Original issue is fixed and link is inserted at the cursor position.

Internal and External links were tested.

There were some other issues when links were inserted.
QA will report them after reviewing already reported bugs.
Comment 3 Calcey QA 2010-03-24 07:31:48 UTC
This is still reproducible in current production environment.
Comment 4 Roan Kattouw 2010-03-24 10:32:06 UTC
(In reply to comment #3)
> This is still reproducible in current production environment.

If it's fixed on the deployment prototype, that's good enough for us. Reclosing.
Comment 5 nkomura@wikimedia.org 2010-03-25 01:52:01 UTC
Today's deployment did not address the issue and IE was blacklisted.  Please give priority for the early resolution.
Comment 6 Adam Miller 2010-03-31 18:54:36 UTC
Fixed this and re-enabled dialogs in IE with r64400.
Comment 7 Calcey QA 2010-05-12 11:56:38 UTC
Fixes are available in IE7, but not fixed in IE 8 yet.
Comment 8 Roan Kattouw 2010-05-12 18:04:53 UTC
(In reply to comment #7)
> Fixes are available in IE7, but not fixed in IE 8 yet.

Works for me in both IE8 and IE8 as IE7, both locally and on prototype.
Comment 9 Calcey QA 2010-05-19 06:26:29 UTC
Reporting against Babaco Release : r66628 
Tested link :http://prototype.wikimedia.org/en.wikipedia.org/Main_Page

Status : verified bug is not reproducible and closed

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links