Last modified: 2012-11-17 14:39:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22816 - Search and replace dialog broken in Opera
Search and replace dialog broken in Opera
Status: RESOLVED DUPLICATE of bug 22358
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Lowest major (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-03-12 12:11 UTC by Calcey QA
Modified: 2012-11-17 14:39 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_2010-03-12_search_Replace.pdf (13.47 KB, application/pdf)
2010-03-12 12:11 UTC, Calcey QA
Details

Description Calcey QA 2010-03-12 12:11:51 UTC
Created attachment 7192 [details]
Wiki_2010-03-12_search_Replace.pdf

Reporting against Babaco Release : http://prototype.wikimedia.org/deployment-en/ 
Tested link :r63174

Steps to Reproduce ::

1) Type some text Example:
test calcey
test calcey 
test calcey
2) then replace all them with 
test qa


<<result : test qatest qaytest qay >>

Expected Outcome::
test qa instead of test calcey, A proper replace for all the matching words.


Test Environment::
Opera/9.80 (X11; Linux i686; U; en) Presto/2.2.15 Version/10.00

Opera/9.80 (Macintosh; Intel Mac OS X; U; en) Presto/2.2.15 Version/10.10


Opera/9.63 (Windows NT 6.1; U; en) Presto/2.1.1

Opera/9.80 (Windows NT 6.1; U; en) Presto/2.2.15 Version/10.00
Comment 1 Roan Kattouw 2010-03-12 12:26:23 UTC
Are the Find next and Replace Next features also broken in Opera? Line breaks and empty lines seem to cause this bug, so try finding/replacing "Calcey" in:

Foo

Bar
Calcey


for instance.
Comment 2 Calcey QA 2010-03-12 12:37:30 UTC
test calcey 
test calcey

When i click on find, it highlight the first calcey and then only highlight calce in the next line

Replace next also the same. replace only upto calce in the 2nd word
Comment 3 Roan Kattouw 2010-03-12 12:47:28 UTC
(In reply to comment #2)
> test calcey 
> test calcey
> 
> When i click on find, it highlight the first calcey and then only highlight
> calce in the next line
> 
> Replace next also the same. replace only upto calce in the 2nd word

I thought so. This means the search&replace dialog is completely broken in Opera, changing summary accordingly. I'll discuss whether we want to fix this (we have an old hack for this bug lying around somewhere called fixOperaBrokenness) or whether we just want to disable search&replace in Opera.
Comment 4 Roan Kattouw 2010-03-15 19:32:28 UTC
Blacklisted Opera for search&replace dialog in r63778.
Comment 5 Andre Klapper 2012-11-17 14:39:22 UTC
[Getting rid of RESOLVED LATER resolution - changing to DUPLICATE in this case.]

*** This bug has been marked as a duplicate of bug 22358 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links