Last modified: 2012-04-19 21:43:29 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22815 - JS error occur on adding a link / adding a table . IE7 / 8
JS error occur on adding a link / adding a table . IE7 / 8
Status: CLOSED WORKSFORME
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal critical (vote)
: ---
Assigned To: Adam Miller
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-03-12 10:47 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_2010-03-12_LinkErr_IE8.pdf (71.86 KB, application/pdf)
2010-03-12 10:47 UTC, Calcey QA
Details

Description Calcey QA 2010-03-12 10:47:20 UTC
Created attachment 7191 [details]
Wiki_2010-03-12_LinkErr_IE8.pdf

Reporting against Babaco Release : http://prototype.wikimedia.org/deployment-en/ 
Tested link :r63174

Steps to Reproduce ::

1) Click on link icon
<<Browser JS error shows as in the attachment>>

Expected Outcome::
Users should be able to add links using IE8


Test Environment::

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Safari/530.17

Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.2; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Comment 1 Roan Kattouw 2010-03-12 12:17:18 UTC
The error message is "context.$iframe.0 is null or not an object", which presumably means there's leftover unconditional references to context.$iframe in IE-specific code.
Comment 2 Adam Miller 2010-03-16 18:31:52 UTC
Unable to replicate in IE 7 or 8 on http://prototype.wikimedia.org/deployment-en/ 

Perhaps something else we changed since the 12th unintentionally fixed this issue as well.
Comment 3 Calcey QA 2010-03-17 05:31:11 UTC
Verified and closed

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links