Last modified: 2012-04-19 21:43:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22494 - Post-insert selection off by one or a few characters
Post-insert selection off by one or a few characters
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Adam Miller
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-02-12 07:27 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_r62243_2010-02-12_TextHighlight.pdf (32.11 KB, application/pdf)
2010-02-12 07:27 UTC, Calcey QA
Details

Description Calcey QA 2010-02-12 07:27:17 UTC
Created attachment 7111 [details]
Wiki_r62243_2010-02-12_TextHighlight.pdf

Reporting against Babaco Release : r62243

Steps to Reproduce ::

Please refer the attachment


Expected Outcome::
Only the text should be highlighted without highlighting the syntax
Comment 1 Roan Kattouw 2010-02-12 12:49:06 UTC
In which browsers does this happen?
Comment 2 Calcey QA 2010-02-12 13:09:27 UTC
Noted in all
Comment 3 Calcey QA 2010-02-12 16:44:24 UTC
One equal sign is highlighted along with the text when a heading is inserted using drop down in enhanced toolbar.

Please see the first picture in the attachment of original bug report.


Also text is not always selected.

Steps to reproduce:
1) Start editing a page
2) Insert a heading using drop down
3) Repeat adding different headings using drop down 

Text in headings are not highlighted sometimes.
Comment 4 Roan Kattouw 2010-03-16 17:39:37 UTC
Adam, could you see if this bug still happens in a non-iframe (i.e. textarea) environment?
Comment 5 Adam Miller 2010-03-16 22:07:20 UTC
Checked with and without iframe in IE 7 & 8, FF 3.6 mac, Safari 4 mac, Opera 10 mac. Works in all of these. If there's a specific browser that you see this not working in, please reopen and be specific about what browser(s) you see it malfunctioning in.
Comment 6 Adam Miller 2010-03-16 23:13:37 UTC
Sorry, some of the things I stated above are incorrect. There was a bug causing the iframe to be loaded in browsers other than Opera even when all labs features were disabled. 

UPDATE: With the iframe disabled, the text selected is indeed wrong in IE 7 and 8. Everything else seems to be working fine for me. In IE 7 and 8 with the iframe disabled, no text is selected and the caret is placed one character into the default text.
Comment 7 Adam Miller 2010-03-31 15:42:09 UTC
Fixed this in r64439
Comment 8 Calcey QA 2010-05-12 12:24:07 UTC
Verified & closed

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links