Last modified: 2012-04-19 21:43:09 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22485 - Cannot select text for copy - happens intermittently
Cannot select text for copy - happens intermittently
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All other
: Normal critical (vote)
: ---
Assigned To: Trevor Parscal
http://en.wikipedia.org
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-02-11 19:45 UTC by nkomura@wikimedia.org
Modified: 2012-04-19 21:43 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_bug_2010-02-12_22485.pdf (49.70 KB, application/pdf)
2010-02-12 04:26 UTC, Calcey QA
Details
Wiki_bug_2010-02-16_22485.pdf (42.64 KB, application/pdf)
2010-02-16 09:02 UTC, Calcey QA
Details
Wiki_2010-03-16_IEerror.pdf (188.62 KB, application/pdf)
2010-03-16 08:16 UTC, Calcey QA
Details

Description nkomura@wikimedia.org 2010-02-11 19:45:48 UTC
In IE8 on Windows 7

Intermittently, text highlight for copy does not work.  The similar issue has been reported at Village Pump of Japanese Wikipedia.  

Script warning that the script is slowing down browsing the page, pops up and prompts to turn off the script.
Comment 1 nkomura@wikimedia.org 2010-02-11 20:17:46 UTC
The problem is reported on IE7 on Vista and IE8 on XP SP3, but does not occur with IE6.
Comment 2 Calcey QA 2010-02-12 04:26:49 UTC
Created attachment 7108 [details]
Wiki_bug_2010-02-12_22485.pdf

Test link:http://prototype.wikimedia.org/deployment-en/
Version:r62243

Able to re-produce the bug. Sections covered by {{ }} can be selected and the other text is not able to.

This is not always producible.But happens.

Bug 22447 raise from the same issue.
Comment 3 Calcey QA 2010-02-12 04:41:25 UTC
(In reply to comment #2)
> Created an attachment (id=7108) [details]
> Wiki_bug_2010-02-12_22485.pdf
> 
> Test link:http://prototype.wikimedia.org/deployment-en/
> Version:r62243
> 
> Able to re-produce the bug. Sections covered by {{ }} can be selected and the
> other text is not able to.
> 
> This is not always producible.But happens.
> 
> Bug 22447 raise from the same issue.

Tested Environments :
Mozilla/4.9(compatible;MSIE 8.0; Windows NT 6.1; Trident/4.0;SLCC2;.NET CLR 2.0.50727;.NET CLR 3.5.30729;.NET CLR 3.0.30729;Media Center PC 6.0)

Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022)
Comment 4 Calcey QA 2010-02-16 09:02:12 UTC
Created attachment 7132 [details]
Wiki_bug_2010-02-16_22485.pdf

Tested link: http://prototype.wikimedia.org/deployment-en/
Version : r62529

IE8 in Windows server
Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022)

When user click on the editor a browser error shows. Please refer the attachment.


IE 8 in Windows 7
Mozilla/4.9(compatible;MSIE 8.0; Windows NT 6.1; Trident/4.0;SLCC2;.NET CLR 2.0.50727;.NET CLR 3.5.30729;.NET CLR 3.0.30729;Media Center PC 6.0)

When user click on editor, the javascript error shows, but the user can continue select text


IE 7
Browser (User-Agent):  Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.21022; .NET CLR 3.5.30729; .NET CLR 3.0.04506) 

When user click on editor, the javascript error shows, but the user can continue select text
Comment 5 Calcey QA 2010-02-16 09:06:12 UTC
(In reply to comment #4)
> Created an attachment (id=7132) [details]
> Wiki_bug_2010-02-16_22485.pdf
> 
> Tested link: http://prototype.wikimedia.org/deployment-en/
> Version : r62529
> 
> IE8 in Windows server
> Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR
> 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022)
> 
> When user click on the editor a browser error shows. Please refer the
> attachment.
> 
> 
> IE 8 in Windows 7
> Mozilla/4.9(compatible;MSIE 8.0; Windows NT 6.1; Trident/4.0;SLCC2;.NET CLR
> 2.0.50727;.NET CLR 3.5.30729;.NET CLR 3.0.30729;Media Center PC 6.0)
> 
> When user click on editor, the javascript error shows, but the user can
> continue select text
> 
> 
> IE 7
> Browser (User-Agent):  Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0;
> SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.21022; .NET CLR
> 3.5.30729; .NET CLR 3.0.04506) 
> 
> When user click on editor, the javascript error shows, but the user can
> continue select text

Another Scenario : if a user copy and paste a text from the editor to the same editor in IE8, and try to select the pasted text, sometimes it not get selected.
Comment 6 Roan Kattouw 2010-02-16 09:44:02 UTC
(In reply to comment #4)
> Created an attachment (id=7132) [details]
> Wiki_bug_2010-02-16_22485.pdf
> 
> Tested link: http://prototype.wikimedia.org/deployment-en/
> Version : r62529
> 
> IE8 in Windows server
> Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR
> 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022)
> 
> When user click on the editor a browser error shows. Please refer the
> attachment.
> 
> 
> IE 8 in Windows 7
> Mozilla/4.9(compatible;MSIE 8.0; Windows NT 6.1; Trident/4.0;SLCC2;.NET CLR
> 2.0.50727;.NET CLR 3.5.30729;.NET CLR 3.0.30729;Media Center PC 6.0)
> 
> When user click on editor, the javascript error shows, but the user can
> continue select text
> 
> 
> IE 7
> Browser (User-Agent):  Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0;
> SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.21022; .NET CLR
> 3.5.30729; .NET CLR 3.0.04506) 
> 
> When user click on editor, the javascript error shows, but the user can
> continue select text
These JS errors were fixed in r62580.
Comment 7 Trevor Parscal 2010-02-17 00:47:12 UTC
You can reproduce this consistently by clicking on the table of contents. The first few items in the TOC will restore selection ability, while all others will break it. There may be some selection bugs that are causing this to happen.
Comment 8 Trevor Parscal 2010-02-18 00:22:20 UTC
Now that we use classified <p> tags instead of adding in <span> tags, this has gone away. We understood it to be the result of setting the selection to within an empty element.
Comment 9 Calcey QA 2010-03-16 08:16:52 UTC
Created attachment 7204 [details]
Wiki_2010-03-16_IEerror.pdf

Please refer the screen print,

An error occur in Windows XP and Windows Server machine IE versions. 

Environments used:
Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022)

Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727)
Comment 10 Calcey QA 2010-03-16 08:17:23 UTC
(In reply to comment #9)
> Created an attachment (id=7204) [details]
> Wiki_2010-03-16_IEerror.pdf
> 
> Please refer the screen print,
> 
> An error occur in Windows XP and Windows Server machine IE versions. 
> 
> Environments used:
> Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR
> 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022)
> 
> Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727)

therefore re-open the bug
Comment 11 Mark A. Hershberger 2011-04-02 04:58:41 UTC
Couldn't reproduce.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links