Last modified: 2012-04-19 21:43:12 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22402 - Leaving usability beta does not turn off the experimental features for users who turned on dialogues and NTOC manually
Leaving usability beta does not turn off the experimental features for users ...
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: High critical (vote)
: ---
Assigned To: Trevor Parscal
All production sites
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-02-06 02:03 UTC by nkomura@wikimedia.org
Modified: 2012-04-19 21:43 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_bug_2010-02-10_22402.pdf (169.76 KB, application/pdf)
2010-02-10 07:57 UTC, Calcey QA
Details

Description nkomura@wikimedia.org 2010-02-06 02:03:11 UTC
User configured experimental features, such as Navigable Table of Contents and Dialogues need to be turned off, if a user leaves the usability beta. 

For Firefox 3/3.5 users, if a user leaves the beta, the classic toolbar in monobook disappears as NTOC is remained turned on.  

The problem could not be reproduced in IE or Opera.  

Steps to produce:

1) Create a new account (to have fresh default preferences)
2) Opt-in to the beta
3) Turn-on NTOC and Dialogues from Preferences (Experimental features under "Edit")
4) Opt out from the beta
5) Open edit tab
6) NTOC is visible and classic toolbar is gone.

Expected behavior:
When a user opt-out from the beta, all experimental features need to be turned off.
Comment 1 nkomura@wikimedia.org 2010-02-06 20:28:37 UTC
Thanks to Trevor and Tomasz, the configuration has been changed so that opting out the beta does turn off all three features.
Comment 2 Calcey QA 2010-02-09 11:38:02 UTC
Was not able to reproduce the defect in all browsers
Comment 3 Calcey QA 2010-02-10 07:57:14 UTC
Created attachment 7094 [details]
Wiki_bug_2010-02-10_22402.pdf
Comment 4 Calcey QA 2010-02-10 08:00:11 UTC
(In reply to comment #3)
> Created an attachment (id=7094) [details]
> Wiki_bug_2010-02-10_22402.pdf

Tested link : http://prototype.wikimedia.org/deployment-en/
Version : r62215

Steps followed:
- Clear the cache
- Connected to the URL
- Selected a random page
- Click on edit

This was shown in both Windows and Fedora environments. Cleared the cache several times and checked, but got the same result. 

Therefore Reopening the bug.
Comment 5 Roan Kattouw 2010-02-10 10:28:45 UTC
Reclosing bug, this one is about production environments. I'll fix the prototype environments later today.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links