Last modified: 2012-04-19 21:43:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22387 - Arabic in IE7 | doubled page width
Arabic in IE7 | doubled page width
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Adam Miller
http://ar.wikipedia.org/wiki/%D8%A7%D...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-02-05 00:46 UTC by nkomura@wikimedia.org
Modified: 2012-04-19 21:43 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description nkomura@wikimedia.org 2010-02-05 00:46:37 UTC
A placeholder bug case for doubled page width for Arabic in IE7.  The issue is in production. Adam is looking into the problem.
Comment 1 Adam Miller 2010-02-05 00:54:15 UTC
I've isolated it to this rule in main-rtl.css: 

#footer #footer-places {
	float: right;
}

If it's not floated, problem goes away. Weird, and probably not the right way to fix it, but that's the simplest solution I've found thus far. Now, I'm not sure how to tell CSS janus to allow a float in LTR but remove it in RTL....
Comment 2 Adam Miller 2010-02-05 16:52:34 UTC
Fixed in r62030. Could be improved upon, since footer elements are not rendering exactly the same in IE7 as other browsers, but the main issue is addressed and the page is now rendering at the correct width in all browsers.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links