Last modified: 2012-04-19 21:43:36 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22348 - Toolbar : Firefox 2.0.0.20 is not responding with any function
Toolbar : Firefox 2.0.0.20 is not responding with any function
Status: CLOSED INVALID
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal critical (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks: 24493 36111
  Show dependency treegraph
 
Reported: 2010-02-02 06:09 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_r61584_2010-02-02_FF2.pdf (22.68 KB, application/pdf)
2010-02-02 06:09 UTC, Calcey QA
Details
Wiki_2010-02-18_FF20020.pdf (40.43 KB, application/pdf)
2010-02-18 08:27 UTC, Calcey QA
Details

Description Calcey QA 2010-02-02 06:09:49 UTC
Created attachment 7059 [details]
Wiki_r61584_2010-02-02_FF2.pdf

Reporting against Babaco Release : r61584

Steps to Reproduce ::

1) Open and edit a random page on Fire Fox 2.0.0.20
<<None of the functions are responding. Example, click on bullet item. Nothing shows in editor. Click on link. Select a page. Click on insert. Nothing happens>>

An error occur in error console. Please refer the screen print.

Expected Outcome::
Since Fire Fox 2.0.0.20 is in eligible list, functionality should work

Test Environment::
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20
Comment 1 Roan Kattouw 2010-02-02 21:28:01 UTC
Hopefully fixed in r61877, please verify.
Comment 2 Calcey QA 2010-02-16 10:33:52 UTC
Tested link: http://prototype.wikimedia.org/deployment-en/
Version : r62529

Bug still available
Comment 3 Trevor Parscal 2010-02-17 18:33:07 UTC
As of r62647 TOC and Dialogs (which caused these issues) are only on for FF3 and above. Toolbar with textarea still remains for FF2.
Comment 4 Calcey QA 2010-02-18 08:27:32 UTC
Created attachment 7146 [details]
Wiki_2010-02-18_FF20020.pdf

Tested Link: http://prototype.wikimedia.org/en.wikipedia.org/Main_Page
Tested Version : r62665

FireFox 2.0.0.20 shows a different tool bar compare to the other versions of Firefox and other browser types. Used the same account on all cases.
Comment 5 Calcey QA 2010-02-18 08:29:58 UTC
(In reply to comment #4)
> Created an attachment (id=7146) [details]
> Wiki_2010-02-18_FF20020.pdf
> 
> Tested Link: http://prototype.wikimedia.org/en.wikipedia.org/Main_Page
> Tested Version : r62665
> 
> FireFox 2.0.0.20 shows a different tool bar compare to the other versions of
> Firefox and other browser types. Used the same account on all cases.

Therefore reopening the bug
Comment 6 Trevor Parscal 2010-02-18 18:20:36 UTC
The toolbar looks different because the dialogs are disabled. This is not a bug.
Comment 7 Roan Kattouw 2010-02-19 10:01:46 UTC
(In reply to comment #6)
> The toolbar looks different because the dialogs are disabled. This is not a
> bug.

To clarify: the TOC and dialogs are not supported in Firefox 2, Safari 3 and Chrome 3 any more.
Comment 8 nkomura@wikimedia.org 2010-02-19 20:17:10 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > The toolbar looks different because the dialogs are disabled. This is not a
> > bug.
> 
> To clarify: the TOC and dialogs are not supported in Firefox 2, Safari 3 and
> Chrome 3 any more.

According to the browser compatibility we provided to Calcey Technologies, Firefox 2.0.0.5 and above is supported.  If we are not supporting any version of FF2, please update the compatibility matrix accordingly.  
http://usability.wikimedia.org/wiki/Releases/Babaco/Compatibility_Matrix
Comment 9 Roan Kattouw 2010-02-19 21:00:34 UTC
(In reply to comment #8) 
> According to the browser compatibility we provided to Calcey Technologies,
> Firefox 2.0.0.5 and above is supported.  If we are not supporting any version
> of FF2, please update the compatibility matrix accordingly.  
> http://usability.wikimedia.org/wiki/Releases/Babaco/Compatibility_Matrix

Matrix updated. There was no column for Chrome 4 (which we do support), and I didn't add one because I didn't know its usage percentage; those percentage probably need to be updated anyway.
Comment 10 Calcey QA 2010-02-24 04:57:19 UTC
Tested link :http://prototype.wikimedia.org/deployment-en/ 
Version : r62874


Checked on Firefox 2.0.0.20 and the error still exists.

Environment:
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20
Comment 11 nkomura@wikimedia.org 2010-02-24 17:20:29 UTC
(In reply to comment #9)
> (In reply to comment #8) 
> > According to the browser compatibility we provided to Calcey Technologies,
> > Firefox 2.0.0.5 and above is supported.  If we are not supporting any version
> > of FF2, please update the compatibility matrix accordingly.  
> > http://usability.wikimedia.org/wiki/Releases/Babaco/Compatibility_Matrix
> 
> Matrix updated. There was no column for Chrome 4 (which we do support), and I
> didn't add one because I didn't know its usage percentage; those percentage
> probably need to be updated anyway.

According to the matrix, FF 2.0.0.5 supports NTOC.  This is causing the confusion in testing as it contradicts to the Comment 7, which says FF2 does not support NTOC.
Comment 12 Roan Kattouw 2010-02-24 17:53:18 UTC
(In reply to comment #11)
> According to the matrix, FF 2.0.0.5 supports NTOC.  This is causing the
> confusion in testing as it contradicts to the Comment 7, which says FF2 does
> not support NTOC.

My mistake, I forgot to remove the 'P' for FF2 in the NTOC row when I last updated the matrix. Fixed now.
Comment 13 Trevor Parscal 2010-02-24 22:16:29 UTC
FF2 is working fine, and I've specifically tested this exact version. The dialogs and TOC are turned off for that browser version. This is not a bug, but yes the documentation was incorrect.
Comment 14 Calcey QA 2010-03-17 06:32:00 UTC
Closed as per comment 13

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links