Last modified: 2011-03-13 18:04:30 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22208 - Toolbar: Reference button doesn't insert <references /> tag
Toolbar: Reference button doesn't insert <references /> tag
Status: CLOSED WONTFIX
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC Windows XP
: Lowest major (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks: 24493
  Show dependency treegraph
 
Reported: 2010-01-21 08:24 UTC by Calcey QA
Modified: 2011-03-13 18:04 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wikibabacor61227_2010-01-21_addreference.jpg (268.52 KB, image/jpeg)
2010-01-21 08:24 UTC, Calcey QA
Details

Description Calcey QA 2010-01-21 08:24:27 UTC
Created attachment 6996 [details]
Wikibabacor61227_2010-01-21_addreference.jpg

Reporting against Babaco Release. (Hosted on http://prototype.wikimedia.org)

Steps to Reproduce ::
1)Start editing a random article
2)Click on 'References' icon to add reference to article
3)Click on 'Show Preview' button to preview article with modifications
<<Error is shown instead of new references added>>

Expected Outcome ::
References shall be listed in article




Test Environment (Client) ::
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.16) Gecko/2009120208 Firefox/3.0.16

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Safari/530.17

Opera/9.80 (Windows NT 5.2; U; en) Presto/2.2.15 Version/10.0

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Comment 1 Roan Kattouw 2010-01-22 20:17:26 UTC
Changing summary, this has nothing to do with the NTOC. The error is thrown by the Cite extension because a <references /> tag needs to be present for <ref> tags for work.
Comment 2 Trevor Parscal 2010-01-26 00:27:34 UTC
It's not clear that we will ever do this. It's certainly not a bug in wikiEditor. If anything, the Cite extension should append a <references /> tag at the end automatically rather than giving the user an error.
Comment 3 Calcey QA 2010-02-24 06:12:36 UTC
Closing the defect as per comment 2

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links