Last modified: 2012-08-04 20:48:44 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22107 - postgresql error when action=creativecommons is used
postgresql error when action=creativecommons is used
Status: RESOLVED DUPLICATE of bug 21196
Product: MediaWiki
Classification: Unclassified
Database (Other open bugs)
1.14.x
Other Solaris
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: postgres
  Show dependency treegraph
 
Reported: 2010-01-15 14:19 UTC by Stoyan Angelov
Modified: 2012-08-04 20:48 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Stoyan Angelov 2010-01-15 14:19:16 UTC
hello all,

after upgrading from mediawiki 1.13.4/postgresql 8.3.6 to mediawiki 1.14.1/postgresql 8.3.8 the following error appears when action=createivecommons is used (e.g. http://<myhost>/index.php?title=FAQ&action=creativecommons)

PHP Warning:  pg_query() [<a href='function.pg-query'>function.pg-query</a>]: Query failed: ERROR:  column &quot;mwuser.user_id&quot; must appear in the GROUP BY clause or be used in an aggregate function in /<mypath>/wiki/includes/db/DatabasePostgres.php on line 578

[Fri Jan 15 15:37:36 2010] [error] [client 85.118.192.131] PHP Stack trace:
[Fri Jan 15 15:37:36 2010] [error] [client 85.118.192.131] PHP   1. {main}() /<mypath>/wiki/index.php:0
[Fri Jan 15 15:37:36 2010] [error] [client 85.118.192.131] PHP   2. MediaWiki->initialize() /<mypath>/wiki/index.php:114
[Fri Jan 15 15:37:36 2010] [error] [client 85.118.192.131] PHP   3. MediaWiki->performAction() /<mypath>/wiki/includes/Wiki.php:63
[Fri Jan 15 15:37:36 2010] [error] [client 85.118.192.131] PHP   4. CreativeCommonsRdf->show() /<mypath>/wikiroot/wiki/includes/Wiki.php:483
[Fri Jan 15 15:37:36 2010] [error] [client 85.118.192.131] PHP   5. RdfMetaData->basics() /<mypath>/wiki/includes/Metadata.php:246
[Fri Jan 15 15:37:36 2010] [error] [client 85.118.192.131] PHP   6. Article->getContributors() /<mypath>/wiki/includes/Metadata.php:77
[Fri Jan 15 15:37:36 2010] [error] [client 85.118.192.131] PHP   7. Database->query() /<mypath>/wiki/includes/Article.php:675
[Fri Jan 15 15:37:36 2010] [error] [client 85.118.192.131] PHP   8. DatabasePostgres->doQuery() /<mypath>/wiki/includes/db/Database.php:570
[Fri Jan 15 15:37:36 2010] [error] [client 85.118.192.131] PHP   9. pg_query() /<mypath>/wiki/includes/db/DatabasePostgres.php:578

the machine runs opensolaris SXCE build 130, x64
Comment 1 Alexandre Emsenhuber [IAlex] 2010-01-15 14:58:12 UTC

*** This bug has been marked as a duplicate of bug 21196 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links