Last modified: 2010-01-22 23:25:37 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22035 - newlines arent being showed in some cases with usability iniative editor
newlines arent being showed in some cases with usability iniative editor
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-06 23:24 UTC by Christopher Baker
Modified: 2010-01-22 23:25 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
screen shot of faulty display (201.95 KB, image/jpeg)
2010-01-06 23:25 UTC, Christopher Baker
Details

Description Christopher Baker 2010-01-06 23:24:35 UTC
I created a page using the editor of the usability initiative. When I edit the page on my computer using FF 3.5.6, the newlines are all there. When my colleague edits the page, the entire page is run together, ignoring all new lines.

I am not sure what browser/OS she is using. I have asked her and will update this when I know more.

I also asked her to make a change to the page and save it, to see if the newlines are gone, or if her browser just isn't recognizing them. I will update when I have more information on this
Comment 1 Christopher Baker 2010-01-06 23:25:49 UTC
Created attachment 6930 [details]
screen shot of faulty display
Comment 2 Roan Kattouw 2010-01-07 08:12:15 UTC
What you're looking at is still experimental software at this point. However, I'd very much like to know which browser this bug appears on.
Comment 3 Christopher Baker 2010-01-08 03:29:38 UTC
Sorry for the delay.

In IE 7.0.6, the edit box displays with no new lines. Visually, it appears as if there is spaces where there should be \n.

It works correctly in FF and chrome, though.
Comment 4 Christopher Baker 2010-01-08 07:36:41 UTC
I believe I have tracked down the source of this bug.

UsabilityInitative/js/plugins/jquery.wikiEditor.html has 'white-space:pre-wrap;' in it's style. According to w3, that means 'Whitespace is preserved by the browser. Text will wrap when necessary, and on line breaks.' When testing this on separate pages in IE and FF, it seems that IE treats this the same as 'normal'. Changing this to wrap does not fix the problem, though.
Comment 5 Roan Kattouw 2010-01-08 09:17:15 UTC
(In reply to comment #4)
> I believe I have tracked down the source of this bug.
> 
> UsabilityInitative/js/plugins/jquery.wikiEditor.html has
> 'white-space:pre-wrap;' in it's style. According to w3, that means 'Whitespace
> is preserved by the browser. Text will wrap when necessary, and on line
> breaks.' When testing this on separate pages in IE and FF, it seems that IE
> treats this the same as 'normal'. Changing this to wrap does not fix the
> problem, though.
> 

The style should be correct: as you said, pre-wrap means "preserve whitespace", which also means preserving newlines. So I don't think this is the cause, but I'll poke at it.
Comment 6 Christopher Baker 2010-01-08 10:21:56 UTC
Exactly. IE 7 does not preserve the white-space or new lines when pre-wrap is specified.
Comment 7 Roan Kattouw 2010-01-22 23:25:37 UTC
Trevor fixed this in r61103.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links