Last modified: 2011-04-30 01:21:40 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21793 - PHP 5.3.1 incompatibility
PHP 5.3.1 incompatibility
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.15.x
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
: newphp, upstream
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-08 05:20 UTC by Tim Starling
Modified: 2011-04-30 01:21 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Tim Starling 2009-12-08 05:20:17 UTC
MediaWiki is not compatible with PHP 5.3.1, due to http://bugs.php.net/bug.php?id=50394 . StubObject is presumably broken if you call it with reference parameters, and ParserFunctions_HookStub is reported as being definitely broken. 

We need to assess the impact and possible workarounds. We may need to do a bugfix release. I will continue to work with the PHP developers to get a solution released (regardless of what Jani says).
Comment 1 Chad H. 2010-01-10 14:11:10 UTC
How should we resolve this now? I see Tim blacklisted 5.3.1 in r60827 and PHP has fixed the regression for 5.3.2.
Comment 2 Brion Vibber 2010-03-05 06:24:04 UTC
I'd consider that as fixed as it's gonna get.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links