Last modified: 2012-04-19 21:43:39 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21709 - Dialogs mysteriously freeze in raw/combined mode but not in minified mode
Dialogs mysteriously freeze in raw/combined mode but not in minified mode
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal blocker (vote)
: ---
Assigned To: Trevor Parscal
:
: 21584 (view as bug list)
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-11-30 04:22 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-11-30 04:22:49 UTC
Reporting against Babaco Release : r59450

Steps to Reproduce ::

1) Select a random page
2) Edit a section
3) Click on link
4) Type in Page title or in link title or try to select option buttons
<<Cannot type or select>>

Expected Outcome::
user should be able to type and select options

Test Environment::
Browser (User-Agent): 	Opera/9.63 (Windows NT 6.0; U; en) Presto/2.1.1

Browser (User-Agent):  	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0 (.NET CLR 3.5.30729)
Comment 1 Calcey QA 2009-11-30 08:19:54 UTC
The same problem is there when typing row and column numbers in insert table function and selecting the check boxes.
Comment 2 Roan Kattouw 2009-11-30 13:07:48 UTC
This is a very mysterious bug that can be fixed by setting the resource mode to minified (will do that later today). I have no idea why it happens with raw and combined and not with minified.
Comment 3 Derk-Jan Hartman 2009-11-30 13:14:35 UTC
sounds like for some reason a global variable is being overwritten.
Comment 4 Roan Kattouw 2009-11-30 16:33:14 UTC
(In reply to comment #3)
> sounds like for some reason a global variable is being overwritten.
> 
Where did you get that idea? When setting $wgUsabilityInitiativeResourceMode = 'raw'; , all the JS and CSS is served raw just fine, same for 'combined'. The bug here is that when this mode is set to 'raw' or 'combined', the dialogs freeze up, while if the mode is set to 'minified' (default), they don't.
Comment 5 Roan Kattouw 2009-12-02 16:31:09 UTC
Fixed in r59666.
Comment 6 Roan Kattouw 2010-01-22 22:18:00 UTC
*** Bug 21584 has been marked as a duplicate of this bug. ***
Comment 7 Calcey QA 2010-01-25 05:49:04 UTC
Verified in r61474 and close

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links