Last modified: 2012-04-19 21:42:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21487 - General : Tab Navigation in Mac FireFox
General : Tab Navigation in Mac FireFox
Status: RESOLVED INVALID
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-11-12 09:35 UTC by Calcey QA
Modified: 2012-04-19 21:42 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-11-12 09:35:00 UTC
Reporting against Babaco Release : r58867

Steps to Reproduce ::

1) Select a random page
2) Edit a section
3) Click on Search and Replace or add link or add table icons
4) Use tab to move within components of the open section
<<after the text boxes tab get itself position in Search box>>


Expected Outcome::
Using tab users should be able to move withing the active section


Test Environment::

Browser (User-Agent): 	Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Comment 1 Roan Kattouw 2009-11-12 10:26:20 UTC
(In reply to comment #0)
> Reporting against Babaco Release : r58867
> 
> Steps to Reproduce ::
> 
> 1) Select a random page
> 2) Edit a section
> 3) Click on Search and Replace or add link or add table icons
> 4) Use tab to move within components of the open section
> <<after the text boxes tab get itself position in Search box>>
> 
> 
> Expected Outcome::
> Using tab users should be able to move withing the active section
> 
Do you mean you expect tabbing will move in circles through the dialog, or do you mean that there are certain elements in the dialog that can't be reached with the tab key?
Comment 2 Calcey QA 2009-11-12 11:08:33 UTC
in this case, the tab is not moving to the buttons. It get stop from the text box and then jump to the search text box. For example, if the link add open, tab should move to link and cancel after the link text box. but in this situation from the link text box it directly goes to Search box which is in the top of the screen. 
Comment 3 DieBuche 2010-12-05 17:57:19 UTC
Similiar problem in chrome. Is this a $j-ui bug?
Comment 4 Brion Vibber 2011-02-14 01:30:18 UTC
On the Mac, by default controls that don't take text input (like buttons, checkboxes, and radio buttons) aren't selectable through hitting tab.

You can change this through System Preferences; here's a random blog post explaining how that I found on google: http://www.paulmc.org/whatithink/2007/12/14/using-tab-to-select-dialog-box-buttons-in-mac-os-x/

Confirmed that tabbing through the dialog controls seems to work fine for me (I keep this preference on since it's so handy!) -- Mac OS X 10.6.6, Firefox 4.0b11.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links