Last modified: 2012-04-19 21:43:18 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21201 - Navigable TOC : Link is become a normal text when it's clicked.
Navigable TOC : Link is become a normal text when it's clicked.
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Trevor Parscal
http://usability.wikimedia.org/wiki/P...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-10-20 09:30 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Bug Desc Screen Shot (282.89 KB, application/pdf)
2009-10-20 09:30 UTC, Calcey QA
Details
Wiki_r58971_2009-11-13_Headers (18.24 KB, application/pdf)
2009-11-13 06:49 UTC, Calcey QA
Details

Description Calcey QA 2009-10-20 09:30:25 UTC
Created attachment 6690 [details]
Bug Desc Screen Shot

Reporting against build r57727

Steps to reproduce :
1) Start editing a new page.
2) Enter following texts into text area.
==Heading text 1==
===Heading text 2===

3) Click on a link available in the Navigable TOC.

<<Link become a normal text after clicked on it. But it's still available in the NTOC.>>

Expected Outcome::
Link should be remains as a link, even after click on it.

Test Environment::
This is reproducible for all the platforms, OS and browsers.
Comment 1 Roan Kattouw 2009-10-26 21:55:08 UTC
It's actually clickable, it just doesn't have a hand when hovering over it. Fixing this should be a simple CSS change (Trevor?).
Comment 2 Roan Kattouw 2009-11-02 11:54:00 UTC
Fixed in r58426.
Comment 3 Calcey QA 2009-11-12 06:21:54 UTC
Reporting against Babaco Release : r58867

Steps to Reproduce ::
Use the same steps as above
Comment 4 Naoko Komura 2009-11-12 19:22:16 UTC
Cannot reproduce.  Feel free to reopen, if it is still an issue.  I tried with FF3.0.15 on Ubuntu 9.0.4 and worked for me. 
Comment 5 Calcey QA 2009-11-13 06:49:05 UTC
Created attachment 6778 [details]
Wiki_r58971_2009-11-13_Headers
Comment 6 Calcey QA 2009-11-13 06:53:59 UTC
(In reply to comment #5)
> Created an attachment (id=6778) [details]
> Wiki_r58971_2009-11-13_Headers
> 

Earlier the link is highlighted when the user click on it or click on the respective text in the editor. 
Now its getting a white background and shows a disabled look but the link can be clicked to move to the respective position.

In Comment #1 it says the CSS change can do the difference but reopened the bug since we didn't saw a difference.

Respective screen print is as of id 6778

Re-Opening the bug again since we see it as a usability issue since user might get confuse that the link got disable when the respective text is clicked.

This shows in all the browsers.
Comment 7 Roan Kattouw 2009-11-13 12:06:16 UTC
(In reply to comment #6)
> Earlier the link is highlighted when the user click on it or click on the
> respective text in the editor. 
> Now its getting a white background and shows a disabled look but the link can
> be clicked to move to the respective position.
> 
> In Comment #1 it says the CSS change can do the difference but reopened the bug
> since we didn't saw a difference.
> 
> Respective screen print is as of id 6778
> 
> Re-Opening the bug again since we see it as a usability issue since user might
> get confuse that the link got disable when the respective text is clicked.
> 
> This shows in all the browsers.
> 
It still has the hand on mouseover for me, which indicates the link can be clicked. Also, this style is in line with the one used in Special characters and Help. Re-closing as FIXED.
Comment 8 Calcey QA 2009-11-13 12:47:32 UTC
Closed according to the comment #6

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links