Last modified: 2014-11-18 18:07:07 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21167 - Make entries in the search suggestions dropdown actual hyperlinks
Make entries in the search suggestions dropdown actual hyperlinks
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.16.x
All All
: Normal enhancement with 2 votes (vote)
: Future release
Assigned To: Bartosz Dziewoński
:
: 28759 (view as bug list)
Depends on:
Blocks: 27411 17808
  Show dependency treegraph
 
Reported: 2009-10-17 12:59 UTC by Tisza Gergő
Modified: 2014-11-18 18:07 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Tisza Gergő 2009-10-17 12:59:18 UTC
The search suggestions which appear in a dropdown when the user starts typing the page title are probably the most effective way of locating something quickly; however, you can only use them to open the requested article in the same tab. I've often found myself in a position where I want to check what a related article says, and - because it had a long name, or I didn't remember the exact wording or spelling - the search suggestion was by far the simplest method of finding it, but I didn't want to navigate away from the current page (which might have been an edit window with changes I didn't want to lose).

Since the search suggestions are not real links but divs which simulate link behavior on a click event, one cannot middle-click them to open in a new tab; I have to select the right one with the keypad, press the right arrow to copy the text to the search box, cut it, open another tab, type en.wikipedia.org/wiki/ then paste it - rather troublesome, especially if one has to do it frequently. If the suggestions were real HTML links, middle click (and Ctrl-click, bookmarking from right-click menu, and all the other UI methods browsers normally provide for links) would work normally, and I see no disadvantage to it.
Comment 1 Brion Vibber 2009-10-19 22:57:26 UTC
Assigning to Trevor for further comment (search box is under development)
Comment 2 Rd232 2011-11-26 22:33:46 UTC
*** Bug 28759 has been marked as a duplicate of this bug. ***
Comment 3 Krinkle 2012-05-11 16:37:51 UTC
I was going to open a similar bug, but glad I don't have to :)

I often use the search for simple titles but want to keep my page and open it in a tab. But neither the title suggestions nor the "Search for <phrase>..." at the bottom can be opened in a new tab.
Comment 4 Bartosz Dziewoński 2012-09-13 17:57:36 UTC
In gerrit: https://gerrit.wikimedia.org/r/#/c/23674/ (based on patch by Ebrahim Byagowi).
Comment 5 Bartosz Dziewoński 2013-01-26 18:44:17 UTC
Change I87940ca8 (linked in previous comment) merged.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links