Last modified: 2012-04-19 21:43:20 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21050 - Insert Link : 'Link text' doesn't mirror 'Page Title' after pressing Backspace in IE and Safari
Insert Link : 'Link text' doesn't mirror 'Page Title' after pressing Backspac...
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC Windows XP
: Normal normal (vote)
: ---
Assigned To: Trevor Parscal
http://prototype.wikimedia.org/deploy...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-10-08 06:15 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-10-08 06:15:37 UTC
Reporting against Babaco Release.

Steps to reproduce::
1)Navigate to a page and click Edit link.
2)Click on 'Link' icon and start to insert a link.
3)Enter 'A' in the 'Page Title' text box.
4)Select one option from the auto populated suggestion list.
<<'Link text' text box should fill up with the same option selected above>>
5)Remove a part from the 'Page Title' using the 'backspace' key.
<<deleting not causing to reduce the content in the 'Link text'>>

Expected outcome::
deleting a part in the 'Page title' shall be cause to remove the same part in the 'Link text' text box.

Test Environment::

Browser (User-Agent):  Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0) 

Browser (User-Agent):	Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.25 Safari/532.0

Browser (User-Agent):	Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Safari/530.17
Comment 1 Roan Kattouw 2009-10-09 19:29:34 UTC
Tweaking summary, cannot reproduce in Firefox 3.0.14. This would seem to be a browser-specific bug where pressing Backspace doesn't trigger a keypress event. Maybe it triggers keydown so we can catch that.
Comment 2 Roan Kattouw 2009-11-12 20:53:44 UTC
Hopefully fixed in r58953, please confirm.
Comment 3 Calcey QA 2010-01-28 08:57:09 UTC
Verified and close

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links