Last modified: 2011-05-15 10:41:53 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21048 - BiDirectional editing - provide a tool to resolve also nested BiDi blocks
BiDirectional editing - provide a tool to resolve also nested BiDi blocks
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Low enhancement with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://yi.wikipedia.org/w/index.php?t...
:
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2009-10-07 23:15 UTC by lɛʁi לערי ריינהארט
Modified: 2011-05-15 10:41 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
screen shot: BiDi gadget - resolve nested BiDi blocks - directionality RTL 01 (156.21 KB, image/png)
2009-10-07 23:15 UTC, lɛʁi לערי ריינהארט
Details
screen shot : BiDi gadget - resolve nested BiDi blocks - directionality override LTR 02 (158.38 KB, image/png)
2009-10-07 23:16 UTC, lɛʁi לערי ריינהארט
Details
screen shot : bug #21048 - BiDirectional editing - provie a tool to resolve also nested BiDi blocks 03. (30.17 KB, image/gif)
2009-10-08 00:32 UTC, lɛʁi לערי ריינהארט
Details

Description lɛʁi לערי ריינהארט 2009-10-07 23:15:27 UTC
Created attachment 6646 [details]
screen shot: BiDi gadget - resolve nested BiDi blocks - directionality RTL 01

Dear friends;

sorry that I open this issue.

It relates to MediaWiki Gadgets based on Brions and Sparklas work:
http://test.wikipedia.org/wiki/MediaWiki:Gadget-BiDiEditing.js
http://test.wikipedia.org/wiki/MediaWiki:Gadget-BiDiEditing2.js

Some existing bugs are related to this topic; I could only identify
bug #12082 add « id="wpTextbox1" » to the « textarea » at « [[special:Emailuser/Foo]] »
bug #12226 add « id="wpTextbox1" » to the « textarea » at « [[special:Upload]] »

Some weeks ago (the 16nd of September, 2009, 01:48) I was realy confused about the gadget.

I will provide two screen shots of the page.
One displaying the editor box in default directionaly (RTL)
and the second displaying the editor box with directionaly override (LTR)

On emay expect that my username « לערי ריינהארט » would show the Hebrew characters in reversed order.

This is not the case because the text in that page (my signature) starts and ends with directional control characters. These are not resolved by the gadgets mentioned above.

Sparkla has made a few years ago the gadget
http://test.wikipedia.org/wiki/MediaWiki:Gadget-EvilUnicodeConverter.js
which beside other things resolves directionaly characters.

request: please provide a way to realy analyse / debug an existing page content

I kindly ask all Mediawiki contributors to work on an (existing editor) and include functionality to allow proper BiDi editing.

Thanks for all your support in advance. Best regards
Reinhardt Wiewe aka « לערי ריינהארט » « 'lɛʁi 'ʁɑjnhɑʁt »
Comment 1 lɛʁi לערי ריינהארט 2009-10-07 23:16:06 UTC
Created attachment 6647 [details]
screen shot : BiDi gadget - resolve nested BiDi blocks - directionality override LTR 02
Comment 2 lɛʁi לערי ריינהארט 2009-10-07 23:24:25 UTC
Please use http://pastebin.com/ to convince yourself.
Comment 3 lɛʁi לערי ריינהארט 2009-10-07 23:34:14 UTC
The world is more then a colection of islands
« تقنيات عربية Bidirectional development »
http://www.facebook.com/group.php?gid=4030495532
Comment 4 lɛʁi לערי ריינהארט 2009-10-08 00:32:39 UTC
Created attachment 6648 [details]
screen shot : bug #21048 - BiDirectional editing - provie a tool to resolve also nested BiDi blocks 03.

This screen shot was made by Splarka.

Thanks for his time spend in the IRC chat. The first important issue is to get aware of the problem.

One solution is to
1. recode the content of a page and resolve the hidden (also the directionality) characters
and
2. allow users to set directionality to either normal or override and to set the orientation to either LTR or RTL

from the chat:
Splarka: (at this momnet / so far) MediaWiki:Gadget-EvilUnicodeConverter.js has a failsafe to prevent them being saved
Gangleri: there is no hurry at all ... the most important is that you have understood the problem

we remembered a chat some weeks ago about BiDirectionality issues; it can be compared to http://images.google.com/images?q=upside+down+world+map&btnG=Google+Images&site=images&num=24&imgsafe=off

Best regards Reinhardt
Comment 5 Amir E. Aharoni 2011-05-15 10:41:53 UTC
I don't understand what the problem is. I looked at the screenshot - that's how bidirectional is supposed to be displayed.

I'm closing this as invalid. If i missed something, please let me know and i'll reopen.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links