Last modified: 2012-04-19 21:43:02 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20991 - Link: 'Link text' text box is not getting filled after delete the content of it
Link: 'Link text' text box is not getting filled after delete the content of it
Status: CLOSED INVALID
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
Macintosh Mac OS X 10.5
: Normal normal (vote)
: ---
Assigned To: Trevor Parscal
http://prototype.wikimedia.org/d/inde...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-10-05 05:07 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-10-05 05:07:20 UTC
Reporting against Babaco Release.

Steps to Reproduce ::
1)Navigate to a Random page and click Edit link.
2)Click 'Link' icon in the toolbar.
3)Type an exiting page name in 'Page title' text box.
<<Link text text box is filled with the entered text>>
4)Delete the 'Link Text' text box content.
5)Type new existing page name in 'Page title' text box again.

<<Link text text box is not filled with the entered text>>

Expected Outcome ::
Link text text box shall be filled with the entered text.

Test Environment ::
Browser (User-Agent):  	Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Time and Date: 	10:16:18 AM - Monday, October 05, 2009
Javascript: 	Enabled
Cookies Enabled: 	Enabled
Java Enabled: 	Enabled
CPU class/type: 	OS/CPU Intel Mac OS X 10.5

Browser (User-Agent): 	Opera/9.50 (Macintosh; Intel Mac OS X; U; en)
Time and Date: 	10:36:16 AM - Monday, October 05, 2009
Javascript:	Enabled
Cookies Enabled:	Enabled 
Java Enabled:	Enabled

Browser (User-Agent):	Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-us) AppleWebKit/523.15.1 (KHTML, like Gecko) Version/3.0.4 Safari/523.10
Time and Date:	10:22:39 AM - Tuesday, October 06, 2009
Javascript:	Enabled
Cookies Enabled:	Enabled
Java Enabled:	Enabled
Comment 1 Roan Kattouw 2009-10-05 10:51:22 UTC
(In reply to comment #0)
> Reporting against Babaco Release.
> 
> Steps to Reproduce ::
> 1)Navigate to a Random page and click Edit link.
> 2)Click 'Link' icon in the toolbar.
> 3)Type an exiting page name in 'Page title' text box.
> <<Link text text box is filled with the entered text>>
> 4)Delete the 'Link Text' text box content.
> 5)Type new existing page name in 'Page title' text box again.
> 
> <<Link text text box is not filled with the entered text>>
> 
> Expected Outcome ::
> Link text text box shall be filled with the entered text.
> 
This is intended behavior. The link text text box mirrors the link target text box as long as the former is not touched. If you change anything in the link text, the software figures you want a custom link text and leaves it alone.

Resolving this as INVALID but CCing the rest of the team for discussion.
Comment 2 Calcey QA 2009-10-13 12:28:00 UTC
agreed & closed

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links