Last modified: 2012-04-19 21:43:00 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20874 - Navigable TOC : The functionality is missing for Opera 9.0
Navigable TOC : The functionality is missing for Opera 9.0
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC Windows Server 2003
: Normal major (vote)
: ---
Assigned To: Trevor Parscal
http://prototype.wikimedia.org/en.wik...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-09-29 12:29 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-09-29 12:29:48 UTC
Reporting against the build hosted on Staging environment.
(http://prototype.wikimedia.org)

Steps to reproduce :
1) Start editing a page with sections
2) Check navigable Table of content in the right side 

<<Navigable table of content is not available >>

Expected Outcome:
Navigable Table of Content shall be available 

Client Environment details ::
Browser (User-Agent):   Opera/9.00 (Windows NT 5.2; U; en)
Javascript:     Enabled
Cookies Enabled:        Enabled
Java Enabled:   Enabled
Screen Width x Height:  1440 x 900
Screen Color Depth:     16
Window Width: 589 (40.9% of 1440) 
Window Height: 353 (39.2% of 900)
Comment 1 Roan Kattouw 2009-09-29 13:17:44 UTC
Further research indicates that the NTOC is mispositioned: add a few dozen headers and you'll see that it's positioned above its desired position. This happens on Opera 9.00 but not on Opera 9.64.
Comment 2 Roan Kattouw 2009-09-29 19:52:08 UTC
Per bug 20883 comment #6 the same issue seems to be happening in IE8.
Comment 3 Roan Kattouw 2009-10-05 21:01:48 UTC
Trevor says this should be fixed with r57403.
Comment 4 Calcey QA 2009-10-06 06:16:23 UTC
Even the Navigable TOC is available functionality is not working correctly.
Please see the bug # 21012.

Also the 'Search and replace' window is not display properly.
It's deffer in size from the other windows open in Firefox, Safari and Chrome.
Comment 5 Roan Kattouw 2009-10-06 10:19:32 UTC
(In reply to comment #4)
> Even the Navigable TOC is available functionality is not working correctly.
> Please see the bug # 21012.
> 
Reclosing the bug, this one is about the NTOC not being there at all, which was fixed.

> Also the 'Search and replace' window is not display properly.
> It's deffer in size from the other windows open in Firefox, Safari and Chrome.
> 
I'll look into that.
Comment 6 Calcey QA 2009-10-06 10:40:17 UTC
Verified and Passed.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links