Last modified: 2012-04-19 21:43:01 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20871 - Navigable TOC: Cursor is not navigating to the correct line when link is clicked
Navigable TOC: Cursor is not navigating to the correct line when link is clicked
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC Windows Vista
: Normal normal (vote)
: ---
Assigned To: Trevor Parscal
http://prototype.wikimedia.org/
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-09-29 10:03 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-09-29 10:03:00 UTC
Reporting against Babaco Release. (Hosted on http://prototype.wikimedia.org)

1)Navigate to a page and click edit Link.
2)Enter several links into the article with some texts like below.

e.g: 
==Link 1==
Text Text Text Text
==Link 2==
Text Text Text Text
====Link 3====
Text Text Text Text

3)Now click on a link in the navigable TOC.

<<Cursor focus goes to another above section of the clicked link.>>

Expected Outcome ::
Cursor focus shall be goes to Corresponding section.

Test Environment (Client) ::
Browser (User-Agent):   Opera/9.80 (Windows NT 5.2; U; en) Presto/2.2.15 Version/10.00
Javascript:     Enabled
Cookies Enabled:        Enabled
Java Enabled:   Enabled
Screen Width x Height:  1024 x 768
Comment 1 Roan Kattouw 2009-09-29 10:27:12 UTC
Fixed in r57048.
Comment 2 Calcey QA 2009-10-01 04:13:10 UTC
Not working for the following browser versions when the same link appear twice in the Navigable TOC.

Test Environment (Client) ::

Browser (User-Agent):  	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Time and Date: 	9:35:49 AM - Thursday, October 01, 2009
Javascript: 	Enabled
Cookies Enabled: 	Enabled
Java Enabled: 	Not Available/Enabled
CPU class/type: 	OS/CPU Windows NT 6.0
Screen Width x Height: 	1024 x 768
Screen Color Depth: 	32 

Browser (User-Agent):	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Safari/530.17
Time and Date:	9:36:03 AM - Thursday, October 01, 2009
Javascript:	Enabled
Cookies Enabled:	Enabled
Java Enabled:	Enabled

Browser (User-Agent): 	Opera/9.80 (Windows NT 6.0; U; en) Presto/2.2.15 Version/10.00
Time and Date: 	9:36:46 AM - Thursday, October 01, 2009
Javascript:	Enabled
Cookies Enabled:	Enabled 
Java Enabled:	Not Available/Enabled 
CPU class/type:	? 
Screen Width x Height:	1024 x 768 
Screen Color Depth:	32

Browser (User-Agent):	Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.21 Safari/532.0
Time and Date:	9:42:19 AM - Thursday, October 01, 2009
Javascript:	Enabled
Cookies Enabled:	Enabled
Java Enabled:	Enabled
Comment 3 Roan Kattouw 2009-10-01 11:56:57 UTC
(In reply to comment #2)
> Not working for the following browser versions when the same link appear twice
> in the Navigable TOC.
Can't reproduce on Firefox 3.5.3, using the following wikitext:

Whee
Whee
(a screenful of "Whee"s)
== Foo ==
(a screenful of "Whee"s)
== Foo ==
(half a screenful of "Whee"s)

Could you be more specific as to exactly what doesn't work, and how to reproduce it?
Comment 4 Roan Kattouw 2009-10-04 13:12:55 UTC
The issue mentioned in comment #2 could possibly be the one that was fixed in r57304; can you verify that?
Comment 5 Roan Kattouw 2009-10-09 20:00:23 UTC
Closing as FIXED; can't reproduce (see comment #3) and I'm pretty sure I fixed it already. Please REOPEN if you can reproduce this.
Comment 6 Calcey QA 2009-10-14 08:12:02 UTC
verified and passed

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links