Last modified: 2009-09-23 13:56:13 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20773 - Localisation cache dependency objects from extensions kill site when extension is disabled
Localisation cache dependency objects from extensions kill site when extensio...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
unspecified
All All
: Normal critical (vote)
: ---
Assigned To: Tim Starling
:
Depends on:
Blocks: 18604 19312
  Show dependency treegraph
 
Reported: 2009-09-22 21:48 UTC by Brion Vibber
Modified: 2009-09-23 13:56 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Brion Vibber 2009-09-22 21:48:25 UTC
This nicely broke the site for a few minutes after I briefly enabled, then re-disabled LocalisationUpdate:

Sep 22 21:38:22 10.0.2.250 apache2[13018]: PHP Fatal error: LocalisationCache::isExpired() [function.LocalisationCache-isExpired]: The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "LUDependency" of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /usr/local/apache/common-local/wmf-deployment/includes/

As a temp workaround I tossed an LUDependency stub class definition into CommonSettings and ran a cache rebuild to eventually work them all out of cache.

We need to gracefully handle dependencies that can't be restored from the cache.
Comment 1 Roan Kattouw 2009-09-23 13:08:53 UTC
Note for folks trying to reproduce this at home: I've discovered that this bug only happens because WMF disabled LU without touching LocalSettings.php ; on normal installs, LocalSettings.php will be changed in the process of disabling LU, which triggers a l10ncache rebuild.
Comment 2 Roan Kattouw 2009-09-23 13:56:13 UTC
Should be fixed with r56816. Note that all attempts to reproduce this bug locally failed, because it cannot occur in theory: there's a GlobalDependency checking $wgExtensionMessagesFiles before any extension-added dependencies, and the former should fire since disabling an extension obviously changes the value of $wgExtensionMessagesFiles, which means the ghost LU object should never be reached.

In short, a theoretically unreachable code path was somehow reached anyway and exploded; this should now be fixed.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links