Last modified: 2012-04-19 21:43:26 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20588 - Navigable TOC : Table is not refreshed when sections added using external editor
Navigable TOC : Table is not refreshed when sections added using external editor
Status: CLOSED INVALID
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC Windows Vista
: Normal minor (vote)
: ---
Assigned To: Trevor Parscal
http://usability.wikimedia.org/wiki/R...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-09-10 20:17 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-09-10 20:17:33 UTC
Reporting against Babaco Release. (Hosted on http://prototype.wikimedia.org)

Steps to Reproduce ::
1)Install an external editor as explained in Wiki documentation
2)Start editing a page with section
3)Edit the page content using external editor
4)Add few sections and save the changes 

<<Newly added sections are not listed in Navigable Table of content >>


Expected Outcome ::
Table of content shall be updated when sections are added/deleted/updated. 


Test Environment (Client) ::
Browser (User-Agent):  	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Javascript: 	Enabled
Cookies Enabled: 	Enabled
Java Enabled: 	Enabled
CPU class/type: 	OS/CPU Windows NT 6.0
Screen Width x Height: 	1280 x 800
Screen Color Depth: 	32
Comment 1 Roan Kattouw 2009-09-22 14:48:09 UTC
The text in the textarea is also not updated in this case, so it's expected that added sections aren't listed.

As far as MediaWiki is concerned, edits made with an external editor are completely detached from any other edit forms you may be looking at in your browser. When you're editing the same page in two different tabs and save one version, it's also logical that the second tab doesn't magically detect this and update its NTOC (which might not even be possible, due to conflicting changes). External editors are no different from having another tab with an edit form open.
Comment 2 Calcey QA 2009-09-29 05:01:50 UTC
Added keyword babaco to the bug
Comment 3 Calcey QA 2009-10-13 12:48:20 UTC
agree and close

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links