Last modified: 2012-10-04 09:53:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20403 - PDF Font rendering for bengali wiki not properly done
PDF Font rendering for bengali wiki not properly done
Status: RESOLVED DUPLICATE of bug 28206
Product: MediaWiki extensions
Classification: Unclassified
Collection (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Volker Haas
http://bn.wikipedia.org
:
Depends on:
Blocks: 31552 40760
  Show dependency treegraph
 
Reported: 2009-08-26 09:53 UTC by Jayanta Nath
Modified: 2012-10-04 09:53 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
All Indic PDF rendering (351.35 KB, image/jpeg)
2011-08-26 05:29 UTC, Jayanta Nath
Details

Description Jayanta Nath 2009-08-26 09:53:18 UTC
When we create PDF version of any page of Bengali Wikipedia,Bengali Font rendering for not properly done.Specially JuktaKKha(complex letter) e-kar(vowel) and i-kar(vowel) is not placed proper postition. 
You can check your side.

http://bn.wikipedia.org/w/index.php?title=%E0%A6%AC%E0%A6%BF%E0%A6%B6%E0%A7%87%E0%A6%B7:Book/download/&collection_id=e2bcc5f70c37ff80&writer=rl&return_to=%E0%A6%AD%E0%A6%BF%E0%A6%95%E0%A6%BE%E0%A6%B0%E0%A7%81%E0%A6%A8%E0%A6%A8%E0%A7%87%E0%A6%B8%E0%A6%BE+%E0%A6%A8%E0%A7%81%E0%A6%A8+%E0%A6%B8%E0%A7%8D%E0%A6%95%E0%A7%81%E0%A6%B2+%E0%A6%8F%E0%A6%A8%E0%A7%8D%E0%A6%A1+%E0%A6%95%E0%A6%B2%E0%A7%87%E0%A6%9C


Jayanta Nath
user id joy
admin,Bengali Wikipedia
Comment 1 Volker Haas 2009-09-01 10:11:26 UTC
Thanks for the info. The problem is that the PDF toolkit we are using (reportlab.org) does not support ligatures. I need to check how ligature handling could be supported by reportlab. I expect this to be rather hard, therefore a solution will take a while. But I'll try to resolve this since other languages are also affected.
Comment 2 Sadik Khalid 2009-09-01 16:08:42 UTC
I think this is a duplicate of https://bugzilla.wikimedia.org/show_bug.cgi?id=19830
Comment 3 Brion Vibber 2009-09-03 01:41:59 UTC

*** This bug has been marked as a duplicate of bug 19830 ***
Comment 4 Jayanta Nath 2011-08-26 05:29:37 UTC
Created attachment 8975 [details]
All Indic PDF rendering

As bug 19830 fixed
https://bugzilla.wikimedia.org/show_bug.cgi?id=19830

Volker Haas is requested to open Indic scripts bug separate

I am just attaching this page http://en.wikipedia.org/wiki/Wikipedia:Enabling_complex_text_support_for_Indic_scripts
Comment 5 Srikanth Logic 2012-01-21 15:10:12 UTC

*** This bug has been marked as a duplicate of bug 28206 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links