Last modified: 2009-08-26 01:43:41 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20379 - A category has been categorised to itself
A category has been categorised to itself
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Categories (Other open bugs)
1.16.x
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-25 05:13 UTC by FrankLSF95
Modified: 2009-08-26 01:43 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description FrankLSF95 2009-08-25 05:13:54 UTC
See http://zh.wikipedia.org/wiki/Category:%E5%B4%87%E6%8B%9C%E6%89%8D%E5%A5%B3Liangent%E7%9A%84%E7%BB%B4%E5%9F%BA%E4%BA%BA. The template [[zh:Template:User Liangent]] will automate automatically categorise the page into a category(http://zh.wikipedia.org/wiki/Category:%E5%B4%87%E6%8B%9C%E6%89%8D%E5%A5%B3Liangent%E7%9A%84%E7%BB%B4%E5%9F%BA%E4%BA%BA) because of the <includeonly>. However, when the category page itself transcludes the template, it will be automate automatically categorised into its own category. This will cause an infinite recursion that the category will become a subcategory of itself. I know one of the solution is to remove that template, but since these occasions quite often appears, could you please fix this bug in order to prevent such occasions? Hope this will not take too much of your time. Thank you.
Comment 1 Mike.lifeguard 2009-08-25 05:30:01 UTC
This isn't a bug, so far as I know. You should add an |nocategory=yes parameter so you can have the template appear on a page without categorizing it. There are plenty of examples, please email me if you cannot figure out how to do this.
Comment 2 FrankLSF95 2009-08-26 01:43:41 UTC
Solved. Thanks.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links