Last modified: 2010-09-08 15:17:03 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20266 - Browse history by user type
Browse history by user type
Status: RESOLVED DUPLICATE of bug 16619
Product: MediaWiki
Classification: Unclassified
History/Diffs (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-15 17:47 UTC by Salem
Modified: 2010-09-08 15:17 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Salem 2009-08-15 17:47:09 UTC
To browse page history for changes made by user type, i.e. see only the changes made by bots or users with IP addresses or admins etc. Also changes made by specific user.
Comment 1 Splarka 2009-08-16 04:48:10 UTC
(In reply to comment #0)
> see only the changes made by bots

If you mean changes made by users who were bots at the time, this can't be done because that data is discarded. It only affects the Recent Changes table. In fact, with the new API parameters, it is possible for a bot, each time, to choose whether to make a bot edit or not.

The same applies for other rights, there is no way to fully and accurately determine what rights a user had when they made an edit, only their current rights. If however, you want to see edits based on the user's current rights, this can possibly be done, but might be a very expensive query.

> Also changes made by specific user.

This can be done via the API already, eg:
http://en.wikipedia.org/w/api.php?action=query&prop=revisions&rvuser=Splarka&titles=Wikipedia:Village%20pump%20(technical)

Comment 2 Roan Kattouw 2009-08-16 11:00:25 UTC
(In reply to comment #1)
> The same applies for other rights, there is no way to fully and accurately
> determine what rights a user had when they made an edit, only their current
> rights. If however, you want to see edits based on the user's current rights,
> this can possibly be done, but might be a very expensive query.
> 
It wouldn't necessarily be expensive, but it would sort by user first, then by timestamp, which is not generally considered a useful ordering.

> > Also changes made by specific user.
> 
> This can be done via the API already, eg:
> http://en.wikipedia.org/w/api.php?action=query&prop=revisions&rvuser=Splarka&titles=Wikipedia:Village%20pump%20(technical)
> 
And since this one is efficient and provides a sane ordering, it could be implemented in the UI as well.
Comment 3 Chad H. 2010-09-08 15:17:03 UTC

*** This bug has been marked as a duplicate of bug 16619 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links