Last modified: 2013-04-08 16:45:33 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20010 - Glossary: Multiple HTML tags in output
Glossary: Multiple HTML tags in output
Status: RESOLVED WONTFIX
Product: MediaWiki extensions
Classification: Unclassified
Glossary (Other open bugs)
unspecified
All All
: Lowest critical (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-30 12:21 UTC by David Hicks
Modified: 2013-04-08 16:45 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description David Hicks 2009-07-30 12:21:29 UTC
From http://www.mediawiki.org/wiki/Extension:Glossary#Multiple_HTML_tags_in_output

**NOTE that the proposed solution below is a little bit ugly... there is probably a better way of doing the same thing**


The Glossary plugin will create multiple <html> tags within the same output page which is invalid and causes undefined browser rendering behaviour. This has been reproduced with MediaWiki 1.15.0 and is caused by ParserBeforeTidy only parsing the user content of the page (rather than the entire HTML output that is sent to the client). To resolve this problem, open up Glossary.php and find:

            if (glossaryParseThisNode($doc, $doc->documentElement, $term)) {

And replace it with:

            $body_element = $doc->getElementsByTagName('body')->item(0);
            if (glossaryParseThisNode($doc, $body_element, $term)) {

Then a few lines down, find:

              $doc->documentElement->appendChild($span);

And replace with:

              $body_element->appendChild($span);

Finally, find:

         $text = $doc->saveHTML();

And insert the following immediately below:

        $text = substr($text, strpos($text, '<body>'), -16);
Comment 1 Quim Gil 2013-04-08 16:45:33 UTC
http://www.mediawiki.org/wiki/Extension:Glossary says 

"This extension has been archived.

This extension is obsolete.
The following other choices are available:

    Lingo
    Terminology"

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links