Last modified: 2009-07-22 22:42:55 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 19874 - Add configuration option to mask file extensions for image description pages
Add configuration option to mask file extensions for image description pages
Status: RESOLVED DUPLICATE of bug 4421
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-22 07:39 UTC by Robert Rohde
Modified: 2009-07-22 22:42 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Robert Rohde 2009-07-22 07:39:37 UTC
Currently image description pages have URLs that end in the same extension as the file they are referencing.  Unfortunately it is not uncommon for search engines and other utilities to assume that any URL ending in ".jpg", ".png", etc. is an image file rather than a content page.  Much as it would be nice if everyone checked content-type declarations there are many practical examples where this is not done.

I would propose the creation of a configuration option to allow image description pages to mask these extensions in their url.  That would allows sites that are concerned about type confusion to get around the problem.

For example, one could automatically convert ".jpg" to "_jpg" (or some other similar translation scheme) at the end of the image description page link.  Alternatively one could append ".htm" to the end of the link or simply strip the extension entirely (though this latter option means dealing with naming collisions).
Comment 1 Chad H. 2009-07-22 22:42:55 UTC

*** This bug has been marked as a duplicate of bug 4421 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links