Last modified: 2009-07-22 22:39:56 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 19869 - SUL not always checked on account creation
SUL not always checked on account creation
Status: RESOLVED DUPLICATE of bug 15545
Product: MediaWiki
Classification: Unclassified
User login and signup (Other open bugs)
unspecified
All All
: Normal critical (vote)
: ---
Assigned To: Brion Vibber
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-22 03:36 UTC by William Allen Simpson
Modified: 2009-07-22 22:39 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description William Allen Simpson 2009-07-22 03:36:06 UTC
It is still possible to create similarly named accounts.

Assume that "User:Crashtestdummy" or "User:CrashTestDummy" exists and is SUL.

When trying to create "User:Crash Test Dummy" on a site (say en.wikipedia) 
where Crashtestdummy already exists, there is an error, because the name is 
too similar.  Good!

When trying to create "User:Crash Test Dummy" on a site (say en.wiktionary) 
where Crashtestdummy does not exist, there is no error. Then, immediately 
do a special:merge account, and voila!  Similarly named SUL account, viable 
on all sites.
Comment 1 Chad H. 2009-07-22 22:39:56 UTC

*** This bug has been marked as a duplicate of bug 15545 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links