Last modified: 2012-09-27 01:11:06 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 19866 - border color of thumbnails on colored backgrounds
border color of thumbnails on colored backgrounds
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-21 22:10 UTC by Sebastian Rittau
Modified: 2012-09-27 01:11 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sebastian Rittau 2009-07-21 22:10:30 UTC
Please see http://de.wikipedia.org/wiki/Benutzer:Srittau/Bugtest?useskin=vector for an illustration of the problem: A thumbnail on a non-white background is displayed with a white border with differing sizes on each side. This is due to the misuse of the border attribute.

The problem can be fixed (on FF) by changing the following rules in main-ltr.css:

  * Removing border-color and border-style from div.thumb
  * Removing border-width from div.tright, instead adding "margin-left: 1.4em"

I don't know if other things will break, though. Nevertheless the rules above look very hacky, change-until-it-works-like and should be reworked in any case.

(The same problem exists for the monobook skin, but this has been worked around on the German Wikipedia, at least.)
Comment 1 Trevor Parscal 2009-07-21 22:25:02 UTC
Solved in r53628.
Comment 2 Derk-Jan Hartman 2009-07-21 23:56:37 UTC
See also my comment in bug 16272, which dealt with the same issue.
Comment 3 entlinkt 2010-07-23 23:23:56 UTC
r53628 doesn't fix anything because this bug (essentially a dupe of bug 8814) is about borders, not backgrounds.

Note that the problem is no longer visible at dewiki because the workaround from [[de:MediaWiki:Monobook.css]] has been copied to [[de:MediaWiki:Vector.css]].

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links