Last modified: 2010-07-22 12:01:25 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 19776 - EditToolbar: '''Bold Text''' inserted into textarea when hitting "enter" in the summary field
EditToolbar: '''Bold Text''' inserted into textarea when hitting "enter" in t...
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal minor (vote)
: ---
Assigned To: Trevor Parscal
http://en.wikipedia.org/wiki/User_tal...
:
Depends on:
Blocks: 24493
  Show dependency treegraph
 
Reported: 2009-07-16 23:16 UTC by Derk-Jan Hartman
Modified: 2010-07-22 12:01 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Derk-Jan Hartman 2009-07-16 23:16:57 UTC
Specifically, this is about a conflict between the new toolbar and wikEd, where '''Bold Text''' is inserted in the edit textarea, when you hit "enter" from the summary field in order to submit. For the WikEd bugreport see the URL.
Comment 1 Trevor Parscal 2009-07-21 23:35:58 UTC
What browser is this happening in? In FF the toolbar buttons don't work at all, they actually take me to the page in read mode... There's clearly some conflicting things going on here...
Comment 2 Derk-Jan Hartman 2009-07-22 00:03:41 UTC
This was in Safari 4 (and Chrome 2).
Comment 3 Cacycle 2009-07-22 00:46:35 UTC
Will check into it...
Comment 4 Cacycle 2009-07-22 01:40:45 UTC
It also happens in Seamonkey and Firefox 3.5. It is not related to any wikEd event and does not pass the wikEd submit button handler...
Comment 5 Cacycle 2009-07-22 03:16:29 UTC
wikEd adds the (old and new) toolbar to a toolbar wrapper div (wikEd code line 2229, see http://en.wikipedia.org/wiki/User:Cacycle/wikEd.js). The strange auto-submit after pushing any toolbar button as well as after pushing the enter button from the edit summary disappears when commenting line 2242 (wikEdToolbarWrapper.appendChild(wikEdToolbar);) out.
Comment 6 Cacycle 2009-07-22 03:36:15 UTC
To make wikEd compatible with the old toolbar wikEd overwrites/redirects the insertTags() function in edit.js to WikEdInsertTags() (line 11837). Is there something similar I can do for the new toolbar? I have played with doing the same with wpTextbox1's .encapsulateSelection to no avail so far.
Comment 7 Cacycle 2009-07-22 04:47:51 UTC
I have disabled the toolbar wrapping for the new toolbar as a quick temporary fix in wikEd version 0.9.85d.
Comment 8 Cacycle 2009-07-22 13:39:35 UTC
Small correction: I meant that the insertion of '''Bold text''' when return-submitting from the summary has been temp fixed. As for the wikEd compatibility of the new toolbar: A week ago or so the new toolbar was functional in wikEd as far as I can remember. 
Comment 9 Raimond Spekking 2009-08-01 14:50:56 UTC
Summary changed because this issue is not related to wikiEd.

I see this behaviour still at translatewiki.net, running r54150. Using FF 3.5.1 under WinXP.
Comment 10 Trevor Parscal 2009-08-05 17:29:06 UTC
This was caused by the use of <input type="image" src="" /> tags for toolbar buttons rather than <img src="" /> tags - making the form get confused which button to execute when the user pressed enter. Solved in r54463.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links