Last modified: 2009-06-23 01:49:06 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 19290 - French spacing matches where it shouldn't
French spacing matches where it shouldn't
Status: RESOLVED DUPLICATE of bug 3158
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
1.16.x
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 07:01 UTC by Tim Starling
Modified: 2009-06-23 01:49 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Tim Starling 2009-06-19 07:01:09 UTC
The French spacing parser feature, which converts a plain space before punctuation into a non-breaking space, is naively implemented and has undesirable side effects. For instance, the following wikitext:

== !!! READ THIS FIRST !!! ==

is rendered as:

...<span class="mw-headline">&nbsp;!!! READ THIS FIRST&nbsp;!!! </span>...

The present regex matches at the start of HTML elements, as shown, and could also match inside attributes. The solution is probably to either move it into doMagicLinks(), or to implement something like what is there: a method for doing regex substitution on the plain text component of HTML and not on the attributes.

Reported on IRC by MZMcBride.
Comment 1 Brion Vibber 2009-06-23 01:49:06 UTC

*** This bug has been marked as a duplicate of bug 3158 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links