Last modified: 2014-10-24 14:47:37 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18913 - Widgets that use 'validate' modifier break the site on PHP < 5.2.0
Widgets that use 'validate' modifier break the site on PHP < 5.2.0
Product: MediaWiki extensions
Classification: Unclassified
Widgets (Other open bugs)
All All
: Normal enhancement (vote)
: ---
Assigned To: Sergey Chernyshev
Depends on:
  Show dependency treegraph
Reported: 2009-05-25 17:16 UTC by Sergey Chernyshev
Modified: 2014-10-24 14:47 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Sergey Chernyshev 2009-05-25 17:16:15 UTC
When 'validate' modifier ( is used on widget parameters, sites that use PHP version < 5.2.0 break because filter extension is not available:

Proper solution is to upgrade PHP, but code should be modified to display an error in place of a widget.
Comment 1 Andre Klapper 2014-10-24 11:52:58 UTC
The oldest MediaWiki version currently supported is 1.19 and that requires PHP 5.2.3, hence closing this ticket as obsolete.
Comment 2 Sergey Chernyshev 2014-10-24 14:47:37 UTC
Waiting 5 years works pretty well - if nobody is crazy about it, means it doesn't need to be fixed ;)

Note You need to log in before you can comment on or make changes to this bug.