Last modified: 2013-03-16 01:30:27 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18881 - maintenance script to populate rev_len field for old revisions
maintenance script to populate rev_len field for old revisions
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Maintenance scripts (Other open bugs)
unspecified
All All
: Normal enhancement with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 12188 46183
  Show dependency treegraph
 
Reported: 2009-05-22 21:28 UTC by Gurch
Modified: 2013-03-16 01:30 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Gurch 2009-05-22 21:28:13 UTC
This would be useful for various stuff, mostly along the lines of statistics generation, where currently the whole text of every revision has to be fetched, which is obviously quite inefficient and resource-heavy.

It might be too much work; Brion said "it's feasible, but you shouldn't assume it'll be done on any particular installation", but I can't figure out if that means "no" or not. :)
Comment 1 Chad H. 2009-05-23 00:12:20 UTC
Updating product/component.
Comment 2 Happy-melon 2009-05-24 16:08:15 UTC
There's no reason to restrict it to enwiki, even if it does have more revisions than all other WMF wikis put together...
Comment 3 Dan Jacobson 2009-05-25 21:08:31 UTC
Changing summary so all who wish can have and run such a script.

Ah, finally the older part of action=history lists needn't look brain damaged: "why no sizes?"

Maybe make it called by update.php too?

Say, some maintenance scripts are only needed once. Perhaps this
should be put in a sub directory.
Comment 4 Gurch 2009-05-27 06:51:25 UTC
Changing summary as the scope of my original request seems to have been expanded from "english Wikipedia" to "all mediawikis", so the cutoff date will depend on when they upgraded.
Comment 5 p858snake 2009-06-06 12:16:13 UTC
Changing Product: Mediawiki → Wikimedia
Changing Component: Maintenance Scripts → Site Requests
Changing Keywords: (N/A) → Shell
Comment 6 Happy-melon 2009-06-06 15:27:07 UTC
No, the problem is that there *is* no such script.  Someone needs to *write* one before it can be run on WMF.
Comment 7 p858snake 2009-06-06 22:56:18 UTC
(In reply to comment #6)
> No, the problem is that there *is* no such script.  Someone needs to *write*
> one before it can be run on WMF.
This bug is written in the pose of running the script, 12188 is the one requesting the script (in which there is already one patch).
Comment 8 Happy-melon 2009-06-07 09:47:25 UTC
If anything (and per bug12188 c6 by Brion) this is the 'write the script' bug, and bug12188 is the 'run the script' bug.  Or you could say this is a dupe, I guess.  Regardless, the best way to proceed is to actually write the damn script :D
Comment 9 Ilmari Karonen 2010-03-03 20:25:27 UTC
Added maintenance/populateRevisionLength.php in r63221.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links