Last modified: 2009-05-16 17:11:54 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18810 - Color-history view mode - colorized article text to show editor attribution history
Color-history view mode - colorized article text to show editor attribution h...
Status: RESOLVED DUPLICATE of bug 639
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 21:30 UTC by stevertigo
Modified: 2009-05-16 17:11 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description stevertigo 2009-05-15 21:30:57 UTC
I'm sure this has been thought of if not suggested before, but ifnot I'm suggesting it now. This idea is in the context of providing extra modes for viewing articles in addition to the view, edit, and print modes, etc. (sidenote: Print mode could be usable as an alternate viewing mode if only it used some padding around the sides. Will file new bug).

Among these possible modes is a color-history mode, which (after some magic) displays the article text in view mode using a color scheme, each of which is associated with an Username or IP, or else with particular edit diffs.

A sidebar key will show the Usernames in order of the article's current text, and the colors are less important as is the ability to read the text and distinguish one block of edits for another. Of course, links to particular diffs would also be nice, though this might be complicated in modes which color code by editor and not by diff.

Sounds a lot easier than it looks of course. I understand it only insofar as it involves scanning the article's history diffs for changes, associating in some way those changes with their editors, and resolving any merging, conflicts, overlap, and minor edit bias. The app must compile a separate picture of the above, and translating sometimes complicated diff data into some kind of visible code that must be reasonably faithful and not oversimplifying. History depth is also an issue, and to some degree there can be options with regard to what chosen depth, method of sorting, or mode of display are used. Reference tags could also conceivably be attributed to the person who added them, but these are less easy, and might ignore subsequent edits within the tag.

There are probably philosophical aspects involved, but the idea of making it easier to tell who does what seems to be an elementary one.

-SV
Comment 1 Roan Kattouw 2009-05-16 17:11:54 UTC

*** This bug has been marked as a duplicate of bug 639 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links