Last modified: 2011-03-12 20:02:07 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18691 - Imagick support in SVG to PNG conversion
Imagick support in SVG to PNG conversion
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
1.16.x
All All
: Normal normal (vote)
: ---
Assigned To: Bryan Tong Minh
: patch
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 05:45 UTC by Yesid Carrillo
Modified: 2011-03-12 20:02 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Patch to add Imagick support in SVG to PNG conversion (2.26 KB, patch)
2009-05-06 05:45 UTC, Yesid Carrillo
Details

Description Yesid Carrillo 2009-05-06 05:45:16 UTC
Created attachment 6093 [details]
Patch to add Imagick support in SVG to PNG conversion

My provider doesn't like passthru and SVG to PNG conversion is not possible. However they had Imagick extension avaliable.

This patch add support for Imagick in this process. To use it, please add 

$wgSVGConverter = 'Imagick';

to your LocalSettings.php file

Enjoy!
Comment 1 Chad H. 2009-05-06 20:37:24 UTC

*** This bug has been marked as a duplicate of bug 14706 ***
Comment 2 Yesid Carrillo 2009-05-07 01:43:17 UTC
Patch from bug 14706 only apply for bitmaps sources. My patch is for SVG sources.
Comment 3 Yesid Carrillo 2009-12-05 06:16:55 UTC
This patch is not duplicated. It has a better solution for a lot of users. Please consider it.
Comment 4 Yesid Carrillo 2009-12-16 06:37:21 UTC
To make this patch work....

'Imagick' => 'Imagick',

instead of

'Imagick' => null,



Comment 5 Bryan Tong Minh 2011-01-07 23:04:24 UTC
Anybody around here who can compile PHP extensions for Windows, so that I can test this?
Comment 6 Yesid Carrillo 2011-01-08 01:13:22 UTC
Bryan, please try this builds:
http://valokuva.org/?page_id=50
Comment 7 Bryan Tong Minh 2011-01-08 11:50:58 UTC
Assigning to me.
Comment 8 Bryan Tong Minh 2011-03-12 20:02:07 UTC
Done in r83779. Thank you for the patch.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links