Last modified: 2010-12-30 19:07:50 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18486 - an enhancement of the wiki internal links (links to other articles)
an enhancement of the wiki internal links (links to other articles)
Status: RESOLVED DUPLICATE of bug 503
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-16 12:56 UTC by Abdullah Al-Ghonim
Modified: 2010-12-30 19:07 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Abdullah Al-Ghonim 2009-04-16 12:56:47 UTC
i think it it would be much easier for the user and will save the wiki servers some processing time; if the user can get a peek look into the other linked article just by moving the mouse over the link. 

sometimes I need to take an idea [the first few lines] about the other article that is linked to my original one; what I usually do is: I open the new link over the current one or in a new tape then I read the first few lines. however, the rest of the article & the embedded media on it usually got downloaded into my system & cost the wiki server  some amount of time with no value to anyone at all.

if the users get the choice to either open the article or peek on it, I think many of them will choose to peek on the article.

technically, I believe this enhancement will not require any change in the core app; just a few lines in the interface with a little data retrieval modification to get the peek of the article.

the only drawback of this enhancement is: a) if this change got implemented in the user interface by using java script maybe some of the users will not get the benefit of it. b) if the user peeked into the article then decided to open it, the processing time will be = peek processing + whole page processing; which is will not go with the idea behind this enhancement mostly for the wiki server side .
Comment 1 Happy-melon 2009-04-26 09:10:11 UTC
This functionality is already available through scripts such as [[WP:POPUPS]]. Strongly disaprove of adding it to core JavaScript, doubly so to core code. Page loading and rendering is definitely not the biggest bottleneck in MediaWiki's performance. 
Comment 2 Chad H. 2010-12-30 19:07:50 UTC

*** This bug has been marked as a duplicate of bug 503 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links