Last modified: 2009-04-03 15:48:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18324 - duplicate fieldname in search form
duplicate fieldname in search form
Status: RESOLVED DUPLICATE of bug 18316
Product: MediaWiki
Classification: Unclassified
Search (Other open bugs)
unspecified
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 11:55 UTC by Derk-Jan Hartman
Modified: 2009-04-03 15:48 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Derk-Jan Hartman 2009-04-03 11:55:40 UTC
The current en.wp version of [[Special:Search]] has the following:

<input name="fulltext" type="hidden" value="Advanced search" />
<input type="submit" value="Advanced search" name="fulltext" />

That means that two form field have the same name "fulltext". This breaks a script ([[MediaWiki:Common.js/search.js]]) in en.wp that has the line:

var lStat = searchForm.fulltext;

which now returns an array. This looks like a mistake, though might be intentional.
Comment 1 Chad H. 2009-04-03 13:09:16 UTC

*** This bug has been marked as a duplicate of bug 13316 ***
Comment 2 Chad H. 2009-04-03 13:10:00 UTC
Blah, wrong bug.

*** This bug has been marked as a duplicate of bug 18316 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links