Last modified: 2013-06-18 15:38:29 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18266 - Account creation log should log originating wiki
Account creation log should log originating wiki
Status: RESOLVED WONTFIX
Product: MediaWiki extensions
Classification: Unclassified
CentralAuth (Other open bugs)
unspecified
All All
: Normal normal with 2 votes (vote)
: ---
Assigned To: Victor Vasiliev
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 02:54 UTC by Mark Pellegrini
Modified: 2013-06-18 15:38 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Mark Pellegrini 2009-03-31 02:54:03 UTC
It is not uncommon to see accounts being automatically created these days as a result of SUL. The log entry for these accounts currently looks like this:

(Logs) . . 02:43 . . XXXXXX (talk | contribs | block) was automatically created 

The log should list the originating Wiki. That is to say, it should list the wiki on which the account was originally created.
Comment 1 Mike.lifeguard 2009-03-31 02:56:26 UTC
(In reply to comment #0)
> It is not uncommon to see accounts being automatically created these days as a
> result of SUL. The log entry for these accounts currently looks like this:
> 
> (Logs) . . 02:43 . . XXXXXX (talk | contribs | block) was automatically created 
> 
> The log should list the originating Wiki. That is to say, it should list the
> wiki on which the account was originally created.
> 

To be clear, you mean the home wiki as reported by CentralAuth?
Comment 2 Mark Pellegrini 2009-03-31 03:03:16 UTC
The home wiki and the wiki reported by Centralauth are not always the same thing. Consider the case of [[user:Raul the Mark]], who recently came to the English Wikipedia (to make death threats against me). He registered on the Italian Wikipedia as reported by WatcherSUL in IRC: 

<WatcherSUL>	Raul the Mark@itwiki: http://meta.wikimedia.org/wiki/Special:CentralAuth/Raul%20the%20Mark

But according to the toolserver tool here - http://toolserver.org/~vvv/sulutil.php?user=Raul+the+Mark - he has no home wiki. The log should record that he registered on the Italian Wikipedia. 
Comment 3 Mark Pellegrini 2011-02-03 09:56:29 UTC
Checked this again today and it's apparently fixed.
Comment 4 Krinkle 2011-02-04 14:49:26 UTC
(In reply to comment #3)
> Checked this again today and it's apparently fixed.

It may now correctly show up at toolserver/sulutil, but that's not what this bug is about (therefore re-opening this bug)
The reason it was wrong at the toolserver was most likely the cause of replication lag (toolserver uses a copy of the real database).

The logs created by CentralAuth (autocreate) does not mention the home wiki:

http://commons.wikimedia.org/wiki/Special:Log/newusers?user=Krinkle
13:08, 26 March 2009 Krinkle (talk | contribs | block) Account created automatically ‎

http://zh.wikipedia.org/w/index.php?title=Special:Logs&user=KrinkleSock&uselang=en
03:30, 22 July 2010 KrinkleSock (Talk | contribs) Account created automatically ‎
Comment 5 Nemo 2013-02-21 15:12:40 UTC
Looks like a very bad idea to clutter the logs with such a useless and ephemeral piece of information as the user's homewiki, which is now visible for everyone as Special:CentralAuth anyway.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links