Last modified: 2009-07-20 03:33:59 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17743 - Special:Block is garbled
Special:Block is garbled
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
1.15.x
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
https://test.wiki.krefeld.m-hs.de/pha...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-01 22:20 UTC by Purodha Blissenbach
Modified: 2009-07-20 03:33 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screenshot of garbled Special:Blockip page (26.20 KB, image/png)
2009-03-01 22:20 UTC, Purodha Blissenbach
Details

Description Purodha Blissenbach 2009-03-01 22:20:25 UTC
Created attachment 5871 [details]
Screenshot of garbled Special:Blockip page

The page Special:Blockip is pretty unreadable:
- a series of words top down on the left, meaning unclear,
- some fields to be filled at the right, purpose unclear,
- relations between text and fields cannot be established,
- spelt out html entities,
- spelt out wikitext,
- spelt out html markup,
- text extends outside window way to the right,
- field content extends to the outside of the window,
all in all a mess.

I suggest to measue the lengths of the field lables in the
upper block. If they would wrap to more than 2 lines, let
them be above the field input via colspan="2", and put the
field in an extra row.

I suggest to render all html entities, html markup, and wiki
markup as intended.

I suggest to wrap all text at the right edge of the window.
(Maybe with the *only* exception of the option list which may
not wrap if the browser would not let it wrap)
Comment 1 Niklas Laxström 2009-03-02 07:56:34 UTC
What happened to the one bug per bug??

(In reply to comment #0)
> The page Special:Blockip is pretty unreadable:
> - a series of words top down on the left, meaning unclear,
> - some fields to be filled at the right, purpose unclear,
> - relations between text and fields cannot be established,
> - text extends outside window way to the right,
> - field content extends to the outside of the window,

These are all the same issue caused by too small screen size.
Worst offender is probably the Aanlass dropdown which contains some long item and makes everything stretch behind the right edge.

> - spelt out html entities,
> - spelt out wikitext,
> - spelt out html markup,

Not our fault if you use those before the messages are "fixed" to support. Those should be in an another bug however.

> all in all a mess.
Which is not totally MediaWikis fault...

> 
> I suggest to measue the lengths of the field lables in the
> upper block. If they would wrap to more than 2 lines, let
> them be above the field input via colspan="2", and put the
> field in an extra row.
The effective variable here is screen resolution, no the length of translation.

> 
> I suggest to render all html entities, html markup, and wiki
> markup as intended.
I'll repeat once more: we do not add new raw-html messages.


> I suggest to wrap all text at the right edge of the window.
> (Maybe with the *only* exception of the option list which may
> not wrap if the browser would not let it wrap)
It should wrap perfectly fine, if the issue in the dropdown is fixed.

Comment 2 Mike.lifeguard 2009-03-16 00:19:10 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > The page Special:Blockip is pretty unreadable:
> > - a series of words top down on the left, meaning unclear,
> > - some fields to be filled at the right, purpose unclear,
> > - relations between text and fields cannot be established,
> > - text extends outside window way to the right,
> > - field content extends to the outside of the window,
> 
> These are all the same issue caused by too small screen size.
> Worst offender is probably the Aanlass dropdown which contains some long item
> and makes everything stretch behind the right edge.

As far as I can tell this is the only legitimate complaint here. If you're using a postage-stamp-sized window then I don't know what can or should be done.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links