Last modified: 2011-04-30 01:16:45 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17713 - Anchors produce empty pl_title values in pagelinks table
Anchors produce empty pl_title values in pagelinks table
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Database (Other open bugs)
1.14.x
PC Linux
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 18071 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-28 05:30 UTC by Dan Barrett
Modified: 2011-04-30 01:16 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Dan Barrett 2009-02-28 05:30:31 UTC
Some anchor links produce a bad row in the pagelinks table (empty pl_title value) and the error "Invalid title in result set;" on Special:WantedPages.

Here is a simple test case. Create a wiki article containing these two lines:

[[#test]]
== test ==

In the pagelinks table, you get:

mysql> select * from pagelinks where pl_title = '';
+---------+--------------+----------+
| pl_from | pl_namespace | pl_title |
+---------+--------------+----------+
|     717 |            0 |          | 
+---------+--------------+----------+
1 row in set (0.01 sec)

This happens in 1.14.0 but not in 1.13.2.  In my 1.13.2 wiki, the pagelinks table has zero rows with an empty pl_title, so I assume this new behavior is a bug.
Comment 1 Dan Barrett 2009-03-02 02:37:20 UTC
How serious (or not) is this bug?  Invalid database rows worry me....
Comment 2 Alexandre Emsenhuber [IAlex] 2009-03-03 17:45:07 UTC
fixed in r47983, but this seems to be the same issue as bug 16965.
Comment 3 Dan Jacobson 2009-03-11 21:53:38 UTC
*** Bug 17751 has been marked as a duplicate of this bug. ***
Comment 4 Niklas Laxström 2009-05-27 19:14:26 UTC
*** Bug 18071 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links