Last modified: 2009-02-26 22:05:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17688 - E-mail notification, watchlist bolding and "changed since your last visit" markers not working on Meta
E-mail notification, watchlist bolding and "changed since your last visit" ma...
Status: RESOLVED DUPLICATE of bug 10172
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 21:52 UTC by Roan Kattouw
Modified: 2009-02-26 22:05 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Roan Kattouw 2009-02-26 21:52:08 UTC
For a while now, e-mail notification and everything triggered by non-NULL values of watchlist.wl_notificationtimestamp (unseen edits bolded in Special:Watchlist and marked with green "changed since your last visit" markers in the history) have not worked on Meta, a wiki that does have these things enabled (testwiki doesn't, although it probably should for testing).

Steps to reproduce:
1. Add a page on Meta to your watchlist
2. Enable the "e-mail me when pages on my watchlist are changed" preference and make sure you have a confirmed e-mail address
3. Log out and edit the page anonymously
4. Log back in and go straight to Special:Watchlist without visiting the edited page first
5. Observe that your anonymous edit shows up, but the page isn't bolded (it should be)
6. Click the relevant (hist) link, which takes you to the history view for the edited page
7. Observe that your anonymous edit doesn't have a green "changed since your last visit" marker (it should)

Strangely, all of this works on my local install (running HEAD).
Comment 1 Brion Vibber 2009-02-26 22:02:51 UTC
Looks like we've got some odd behavior related to the way enotif mails are being pushed back into the job queue. Need to nail down how to handle this better, and either prioritize them in the queue or do them without the job queue...

Might be another BZ entry to merge this with, I vaguely recall some related comments.
Comment 2 Danny B. 2009-02-26 22:05:58 UTC

*** This bug has been marked as a duplicate of bug 10172 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links