Last modified: 2009-07-29 19:00:54 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17650 - XHTML validation errors -- some "id" attributes are not unique
XHTML validation errors -- some "id" attributes are not unique
Status: RESOLVED DUPLICATE of bug 7356
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
1.15.x
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: html
  Show dependency treegraph
 
Reported: 2009-02-24 15:04 UTC by Ben Rimmington
Modified: 2009-07-29 19:00 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Ben Rimmington 2009-02-24 15:04:25 UTC
OVERVIEW DESCRIPTION:

The <http://en.wikipedia.org/wiki/Neptune> page is invalid XHTML, because some of the "id" attributes for <cite> elements are not unique.

STEPS TO REPRODUCE:

1. Launch the validator: <http://validator.w3.org/>
2. Enter the address: <http://en.wikipedia.org/wiki/Neptune>
3. Click the "Check" button, or press the Return key.

ACTUAL RESULTS:

- Errors found while checking this document as XHTML 1.0 Transitional!
- Result: 6 Errors
- Line 697, Column 128: ID "CITEREFPodolakWeizman.2C_A..3B_Marley.2C_M.1995" already defined.
- An "id" is a unique identifier...
- ...

EXPECTED RESULTS:

- This document was successfully checked as XHTML 1.0 Transitional!
- Result: Passed
- ...

NOTES:

1. In the wikitext, the <ref name=Podolak1995> and <ref name=pass43> elements contain the same information (except that the first also contains an url).
2. The duplicate "id" attributes don't appear to be used within the XHTML document.
3. Possibly related to Bug 10218 [Sanitizer doesn't validate attribute values according to DTD].
Comment 1 Danny B. 2009-02-24 16:35:24 UTC
There already is some bug about necessity of checking for duplicate id's provided by users through wikitext, however I'm currently unable to find it. Try to search, please, and then mark this as a dupe of it.

I found only mine bug 13926 which is not exactly that one I have in my mind. But it's of similar nature.
Comment 2 Ben Rimmington 2009-02-24 18:12:57 UTC
@Danny B: I found the following bugs:

Bug 4515 [The Sanitizer doesn't validate the contents of id attributes] (resolved as duplicate of 9530).

Bug 6301 [Multiple stub templates in an article make it non-W3C-compliant] (resolved as duplicate of 4515).

Bug 7356 [User-specified HTML IDs can be the same as interface IDs].

Bug 7662 [HTML IDs for headings can be the same than existing IDs] (resolved as duplicate of 7356).

Bug 9530 [Section heading anchors shouldn't begin with invalid characters].

Bug 10218 [Sanitizer doesn't validate attribute values according to DTD].

Bug 11625 [Extensions are Blind to IDs and Anchor Names Already in Use] (resolved as duplicate of 7356).

I don't know if any of those bugs are a match, because in this case the "id" attributes are generated by the parser, not hard-coded by the user. I'm also unaware of what the Sanitizer does, and whether it is responsible for fixing this kind of problem.

Is the wikitext of the <http://en.wikipedia.org/wiki/Neptune> article invalid? Should the <ref name=Podolak1995> and <ref name=pass43> wikitext elements somehow refer to a shared {{cite}} element in the ==References== section, instead of using their own inline {{cite}} elements?

P.S. Is your Bug 13926 a duplicate of Bug 7356? (Comments 6 and 7 also mention using an "mw-" prefix).
Comment 3 Chad H. 2009-07-29 19:00:54 UTC

*** This bug has been marked as a duplicate of bug 7356 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links