Last modified: 2011-05-06 22:33:28 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17515 - Sortable tables using rowspan get messed up on sort
Sortable tables using rowspan get messed up on sort
Status: RESOLVED DUPLICATE of bug 8028
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/Comparis...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 02:00 UTC by PFudd
Modified: 2011-05-06 22:33 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description PFudd 2009-02-16 02:00:18 UTC
On this page (http://en.wikipedia.org/wiki/Comparison_of_CECB_units), there's a long table of products, with a number of columns containing their properties.  At the top of the table, there are headers with buttons that allow for sorting of the table based on the column you select.

If you press one of those buttons (the one for "Smart Antenna") for instance, you'd expect to see the same table, sorted by the contents of that column.

It does produce a table, but it's not sorted by anything obvious, and the table structure starts to break down part way down the page (too many/not enough columns, wrong data in columns, etc).  

It looks like the code for sorting tables can't handle this table, and is dying badly.
Comment 1 Roan Kattouw 2009-02-16 12:27:02 UTC
Tweaking summary to be more generic: AFAICT, it's the usage of rowspan (cells spanning multiple rows) that causes the table to be messed up.
Comment 2 ulyssite 2010-12-24 21:02:01 UTC
Hello,
I also faced that bug.
It produced an ugly table :
http://fr.wikipedia.org/w/index.php?title=Guerre_de_Troie&oldid=60538230

It would be very useful to correct the bug.

Thank you very much,
Ululo
Comment 3 DieBuche 2011-02-20 13:55:03 UTC
.

*** This bug has been marked as a duplicate of bug 8028 ***
Comment 4 Krinkle 2011-05-06 22:33:28 UTC
*** Bug 28859 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links