Last modified: 2012-12-14 05:00:08 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17454 - m.wikipedia.org's "Show" button not expanding section on Nokia N95.
m.wikipedia.org's "Show" button not expanding section on Nokia N95.
Status: RESOLVED WONTFIX
Product: Wikimedia Mobile
Classification: Unclassified
Retired (Ruby) Gateway (Other open bugs)
.5
Other other
: Lowest normal (vote)
: ---
Assigned To: Hampton Catlin
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 23:41 UTC by Nick Jenkins
Modified: 2012-12-14 05:00 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Nick Jenkins 2009-02-11 23:41:06 UTC
On the Nokia N95, the "Show" button does not seem to work for http://m.wikipedia.org/

What happens:
* Open a mobile Wikipedia page, for example: http://m.wikipedia.org/wiki?search=WW1 , on the phone.
* The page loads normally (looks the same as per a desktop machine, just on a smaller & much narrower screen).
* Scroll to the end of the page, and there should be multiple "show" buttons for later sections. So far so good.

The problem:
* Clicking on the "show" buttons has no obvious effect. I.e. The section does not expand, as it does in say Firefox on a desktop machine.

Other info:
* The phone's browser has the "Java/ECMA script" option set to "Enabled".
* I can't readily see a way to get a JavaScript console to see an error message or other debugging info, so I'm unsure what the problem is.

Background info:
* The Nokia N95 phone runs Symbian S60 3rd Edition with Feature Pack 1: http://en.wikipedia.org/wiki/Nokia_N95
* S60 comes bundled with a web browser based on a modified version of WebKit: http://en.wikipedia.org/wiki/Web_Browser_for_S60 , and it's supposed to be a semi-reasonable browser (especially for a mobile device), at least that's what I've heard anecdotally and read online. Whether that is true or not, I don't know.
* S60 has about a 45% market share of smartphones as at Nov 2008: http://en.wikipedia.org/wiki/File:Market_share_of_mobile_os_s_2008.JPG , so assuming it's not a settings/configuration issue on my phone, then it's probably not a niche issue, and reasonable chance may happen on other Nokia smartphones too - but I do not have an easy way of testing that.
Comment 1 Hampton Catlin 2009-02-23 04:36:12 UTC
Unfortunately, this isn't a currently supported device. However, if we had someone who wants to track this down with their N60, I'd be more than willing to get it fixed.
Comment 2 Andre Klapper 2012-12-13 16:43:44 UTC
WONTFIXing to get rid of deprecated LATER resolution - there are currently no plans to investigate or fix this in case that the problem still happens, sorry.
Comment 3 Nick Jenkins 2012-12-14 05:00:08 UTC
Yeah, I completely agree now with WONTFIX. Symbian is effectively a dead OS in the OECD countries, comprehensively out-competed primarily by iOS and Android. In developing countries apparently it's less dead, I'm guessing because the battery life on some of those older devices puts many modern smartphones to shame. But overall as at 2012 Q3, Symbian is down to 2.6% of all new phone shipments, and falling.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links